WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks kills custom "no posts in this category" theme element (1 post)

  1. willdonovan
    Member
    Posted 6 years ago #

    Right, so - I didn't even realize this until today, and it's not a huge deal, but I'm wondering if anyone has a workaround to this issue -

    With this link: http://www.maineinvestmenthomes.com/?cat=4

    I.E. calling the category by it's number, WordPress returns the customized "sorry there ain't anything here" element in my loop. But if it's called by the permalink:

    http://www.maineinvestmenthomes.com/category/open-houses/

    WordPress returns the 404 page. Pain in the butt that is.

    Now obviously I could hardcode the link in, but that sort of defeats the purpose - this is what I have currently, whereby I can call the number of posts and I can bring in a feed icon.

    <h2><li class= "page_item current_page_item" ><?php wp_list_categories('style=none&hide_empty=0&show_count=1&title_li=&include=3&feed_image=http://www.g-8.de/Content/DE/__Bilder/Icons/rss-icon-2-orange,property=default.jpg'); ?></li></h2>
    
    <li class="page_item"><?php wp_list_categories('style=none&hide_empty=0&show_count=1&title_li=&include=4&feed_image=http://www.g-8.de/Content/DE/__Bilder/Icons/rss-icon-2-orange,property=default.jpg'); ?></li>
    
    <li class="page_item"><?php wp_list_categories('style=none&hide_empty=0&show_count=1&title_li=&include=5&feed_image=http://www.g-8.de/Content/DE/__Bilder/Icons/rss-icon-2-orange,property=default.jpg'); ?></li>

    Anyone have any ideas?

Topic Closed

This topic has been closed to new replies.

About this Topic