WordPress.org

Ready to get started?Download WordPress

Forums

WEBphysiology Portfolio
[resolved] Permalinks issue - Can't use pretty ones (8 posts)

  1. boerbabe
    Member
    Posted 7 months ago #

    Is there any variation of pretty permalinks that can be used with this plug-in? The only way I have been able to get it to work is when using the original permalink settings for WordPress, which are quite simply, ugly. I've tried all pre-set options, and with each one (except the post name one), the first page shows up fine in a given portfolio, but each successive pagnated page gives a 404 error.

    Is there some other variation that would work here, or I am I stuck with the default or post names?

    http://wordpress.org/plugins/webphysiology-portfolio/

  2. Jeff
    Member
    Plugin Author

    Posted 7 months ago #

    I use category / post name myself. Can you provide a URL to the site where you are having this problem or provide your custom permalink and I'll test it myself?

  3. boerbabe
    Member
    Posted 7 months ago #

    The site is http://kittyloafdesigns.com/, however, I need to have them working properly as its my work site and I've just finished promoting some of my content which is in the portfolios so can;t really play around with it too much at the moment.

    These are the stock settings I tried, with the negative results listed in my original post.

    Day and name http://kittyloafdesigns.com/2014/01/29/sample-post/
    Month and name http://kittyloafdesigns.com/2014/01/sample-post/
    Numeric http://kittyloafdesigns.com/archives/123

    These are the only two variations without customizing them that everything works fine.

    Default http://kittyloafdesigns.com/?p=123
    Post name http://kittyloafdesigns.com/sample-post/

    I did try any unique custom configurations as of yet. I currently have the permalinks set to http://kittyloafdesigns.com/sample-post/.

    Thanks for the quick response to this- I know its not the most pressing issue the plug-in could have. Otherwise its very nice and I quite like it.

  4. Jeff
    Member
    Plugin Author

    Posted 7 months ago #

    I think the issue is that you are trying to use the Portfolio on a post. It's meant to be used on pages only. Sorry I didn't catch that sooner. So, you can use whatever permalink you want, but you would need to use the shortcode on your portfolio page(s).

  5. boerbabe
    Member
    Posted 7 months ago #

    The shortcode is in pages, not posts.

  6. Jeff
    Member
    Plugin Author

    Posted 7 months ago #

    My bad.

    I just tried every default permalink available and it did break on one of them, numeric. The issue appears to occur if there is no trailing slash in the URL as when the page is added to the nav (e.g., page 2) the slash is missing between the base URL and the page reference. The other defaults, and the custom settings I know, end with a slash. As you click on the various permalinks you'll see this. In the case of the numeric permalink, I simply added a trailing slash and this fixed the issue.

    /archives/%post_id%/

    http://screencast.com/t/ulLvKXSfAlR

  7. boerbabe
    Member
    Posted 7 months ago #

    Interesting... :) That gave me an idea.

    I just went back and tried one of the ones with a trailing slash by default, then checked all of my portfolio pages. All work (included additional pages) EXCEPT the page I had given the slug of "webphys-portfolio" because I hadn't read all the docs and wasn't sure how to implement it into a page. Doh!

    I changed the page slug to something else, and now it works fine, with any permalinks featuring a trailing slash.

    I'm thinking my naming the page slug thus caused some sort of confusion with the plug-in?

  8. Jeff
    Member
    Plugin Author

    Posted 7 months ago #

    That slug may have caused an issue since it may be picked up in my code as a var or something else. Anyway, glad you are back on course.

Reply

You must log in to post.

About this Plugin

About this Topic