WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalinks Issue, and I am my own server administrator (7 posts)

  1. jockoe
    Member
    Posted 6 years ago #

    I can get the "Ugly" permalinks to work, but not the "Pretty" permalinks. I have mod_rewrite enabled on my Apache2 server. My .htaccess file is in the root directory for wordpress. (the folder that I put the wordpress files in is actually "the_tracy_times".) My .htaccess file looks like this...

    Options +Followsymlinks

    # BEGIN WordPress

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /the_tracy_times/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /the_tracy_times/index.php [L]
    </IfModule>

    # END WordPress

    This is my first experience with server administration. It's a Linux server, running Apache2. I've been trying for 3 days to get this working. If anybody can help me get the permalinks working I'd appreciate it.

  2. deuced
    Member
    Posted 6 years ago #

    Where's my .htaccess file?

    WordPress's index.php and .htaccess files should be together in the directory indicated by the Blog address (URI) setting on your General Options page...

    So which is your blog address? You should put .htaccess file there. In your case i think it's http://domainname/the_tracy_times/

  3. whooami
    Member
    Posted 6 years ago #

    -- nevermind --

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    whooami: Huh? Those are the correct rewrite lines to have in the .htaccess. Without those, non-default permalinks of any sort won't work.

    I don't see any hand-edits in that code. That's what WordPress would create normally.

  5. whooami
    Member
    Posted 6 years ago #

    oh, ok, my bad.. hmm, why do I know of 2.5.1 sites that have the standard bits of code, and also have pretty permalinks.

    i JUST Looked, and am looking at a 2.5.1 site with the standard bits in the .htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    and she has pretty permalinks.

    --

    Ok, I need coffee. Just fricken ignore me.

    For some reason I thought I saw actual regex bits [0-9] etc..in the first post.

  6. jockoe
    Member
    Posted 6 years ago #

    and she has pretty permalinks.

    Just for the record... "She", is a "He". :-)

    On to my post... Before I came back here to see if anyone responded to me yet, I got it working. My .htaccess files was already residing in my "the_tracy_times" folder. Thanks for the reply, deuce. My problem had more to do with my server not being configured correctly. Though I did need to enable the Followsymlinks option in my .htaccess file by adding the line "Options +Followsymlinks" to it.

  7. whooami
    Member
    Posted 6 years ago #

    Just for the record... "She", is a "He". :-)

    Just for the record, I wasnt referring to you. :) rather to someone that I know has pretty permalinks working, and who happens to be a female.

    Neither here nor there as I imagined what I saw in your first post.

    back on topic ...

Topic Closed

This topic has been closed to new replies.

About this Topic