WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks issue (17 posts)

  1. Jason_A
    Member
    Posted 5 years ago #

    Hi,

    I'm having an issue with the permalinks. Just installed WordPress and got it all up and running, but when I use the following as a custom structure I get page not found:

    /%post_id%/%postname%/

    Not sure where I'm going wrong so would appreciate a little help.

    Blog here: http://www.techsupportteam.org/blog/

    Kind Regards,
    Jason

  2. Roy
    Member
    Posted 5 years ago #

    Did you read the codes?

    In most cases the problem is:
    1) Your htaccess is not writable;
    2) You don't have mod_rewrite enabled.

  3. Jason_A
    Member
    Posted 5 years ago #

    Yup!

    1) I've had it at 666 -- didn't work. Then put it at 660 and that causes a forbidden page to be shown.
    2) mod_rewrite is enabled on my server. See the forums to see that mod_rewrite is enabled: http://www.techsupportteam.org/forum/.

    Thanks for the reply, anyway.

    Regards,
    Jason

  4. Roy
    Member
    Posted 5 years ago #

    That's weird. Did you try any of the 'default pretty' permalinks?

    [edit] Another thought: some servers for some reason seem to be unable to 'do' pretty permalinks without index.php in them. Now is this entire index.php in permalinks an issue with WP 2.6.1 (I don't know about 2.6.2), but it's worth to try.

  5. Jason_A
    Member
    Posted 5 years ago #

    Yes, I tried the default and they were the same.

    I've tried adding index.php in front and it's the same. I'm stumped.

    Regards,
    Jason

  6. Wendel Brume
    Member
    Posted 5 years ago #

    My hosting service had to do something on their end to get pretty permalinks to work, so you might check with your host.

  7. Jason_A
    Member
    Posted 5 years ago #

    Everything seems to be good on their end -- have no idea what to try next.

    Regards,
    Jason

  8. iridiax
    Member
    Posted 5 years ago #

    One thing to try:

    Leave the category base and tag base blank and choose the Day and name permalink option. Do your permalinks now work?

  9. Jason_A
    Member
    Posted 5 years ago #

    Nope, that doesn't work, either.

    Thanks for the reply, though.

  10. Jason_A
    Member
    Posted 5 years ago #

    bump again -- I can't be the only one who's ever had this problem?

  11. iridiax
    Member
    Posted 5 years ago #

    Contact your web host, they may be able to help you figure it out.

  12. Jason_A
    Member
    Posted 5 years ago #

    I really don't think it's an host problem, since my blog hosted on the same server is having no issues with this. http://www.jasonamison.com/

    Regards,
    Jason

  13. iridiax
    Member
    Posted 5 years ago #

    Things to try:

    Temporarily disable all plugins and see if the problem remains.

    Let WordPress generate a fresh .htaccess file for you, making sure that you have none of your own added custom code in there.

  14. Jason_A
    Member
    Posted 5 years ago #

    Disabled all plugins but still the same. :(

    How do I generate a new .htaccess file? Although I haven't changed anything in there as far as I'm aware.

  15. iridiax
    Member
    Posted 5 years ago #

    How do I generate a new .htaccess file?

    • Change to default permalinks.
    • Rename your .htaccess to something else.
    • Go to the WordPress dashboard and choose a pretty permalinks setting and save changes.
  16. Jason_A
    Member
    Posted 5 years ago #

    Woohoo! That worked! Thank-you very much, iridiax. :)

  17. valtf
    Member
    Posted 5 years ago #

    Hi all,
    This is my first post. An d I come back with a permalinks probrlem.
    This morning I had been updated tu WP 2.6.2. from 2.6.1. The permaliknsk dont work.

    When I activate it, and go to a page, appear a file list of the host.
    If I put deffault permalink work fine.
    Any Idea?
    ThankĀ“s
    Valentin

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.