WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks in 2.6.1 still not working (49 posts)

  1. royfossblog
    Member
    Posted 5 years ago #

    Greetings all,

    Im a relatively new WordPress user, started using it when it was in stage 2.4 or 2.5. I managed to have no problems what so ever with anything except now ever since I've upgraded to 2.6 the permalinks problems started happening. As a good techy, I read all the documentation and tried the various fixes (of which none of them worked for me) So I decided to wait till 2.6.1 which was supposed to address the permalinks issues associted with people using IIS.

    I upgraded to 2.6.1 this morning and Im sorry to say that the permalinks are still not working.

    Ive tried adding Category and Tag, Ive tried not using "index.php" in the link structure, Ive tried every possible combination of link structure and "hacks" but absolutely none of them work except for the default or numeric link structure. This is the reason why I've kept my other blog at 2.5 which works perfectly.

    Please someone give me a recommendation, as i've run out of ideas and probably read every post on permalinks on this website.

    Again I am a IIS user

    Thank you for your time!

  2. royfossblog
    Member
    Posted 5 years ago #

    Hi guys... Still need help on this. I've tried updating the database and applying the fixes mentioned in the sticky on this forum and still no luck. Im not sure what the problem is.

  3. desertdiva
    Member
    Posted 5 years ago #

    OK, add me to the mix. I upgraded to WordPress 2.6.1 and tried all of the fixes that a moderator posted (he closed the thread). I still have "spaces" for my categories and a number, but no description shows up.

  4. desertmagic
    Member
    Posted 5 years ago #

    Add me to the list. My permalink structure was %postname% and now all pages are going to a 404.

  5. desertmagic
    Member
    Posted 5 years ago #

    Okay, I messed around with 2.6.1 and this is how I got my pretty permalinks to work again. Previously I was using %postname% and it broke. Tried using index.php/%postname%/ and that didn't work.

    Solution:
    Use custom structure: %PATHINFO%/

    This will yield the following permalink:

    http://yoursite.com/postname/

  6. jawntech
    Member
    Posted 5 years ago #

    Same problems for me. A 404 Error.

    Not even desertmagic's solution of using %PATHINFO% worked. (but thanks for posting it -- it may work for some, which is a good thing).

    My other blog is running fine on 2.5, and custom structure:%postname% works perfectly.

    Created a new blog, v. 2.6, and permalinks would not work. Heard the permalinks was a common problem, and 2.6.1 would fix it -- didn't for me. I hope I don't need to revert back to 2.5 for the new blog, but it beats having numbers, dates, and symbols in the URL (for this particular site)...

  7. jawntech
    Member
    Posted 5 years ago #

    Ok, I found another solution that worked for me, though not sure why it worked... but it did.

    When setting up the 2.6.1 blog, instead of going straight to the Permalinks tab in Settings first (as I did), go to the "General" page first.

    In the field "WordPress address (URL)", change the url to either have the "www" or not. Click "Save Changes" on the bottom of the page. Then change it back. Repeat, at least to get it to whichever you'll want your blog.

    Then go back to Permalinks, and use /%postname%/ (as I chose), or whatever format you wish. Bingo. It now works.

    Apparently, tinkering with the url settings in the "General" section first, causes WP to create whatever necessary thinga-ma-jigs that are needed to do the permalink stuff. (Pardon the caveman terminology, it's 5 AM)

  8. robhav
    Member
    Posted 5 years ago #

    Still not working for me :-((((

  9. magius2244
    Member
    Posted 5 years ago #

    Same problems for me. A 404 Error as well. I have tried all of the previous solutions and the solutions listed in this support post. I am running IIS as well.

    I thought this issue was resolved...Even when adding the category and tag base names it does NOT work.

    Anyone have any ideas? Thoughts? A rock to hurl at the wall?

  10. royfossblog
    Member
    Posted 5 years ago #

    I've tried all the solutions mentioned above and I am still not able to get my permalinks running as well. Is there any way to switch back to 2.5 without doing any damage? 2.6 or 2.6.1 just have not been working well and Im running out of time playing around with these permalinks :(

  11. magius2244
    Member
    Posted 5 years ago #

    Hello All,

    Just tried a completely fresh install, fresh download of 2.6.1, new database and I still have the same permalink issues I had previously. Unless I use the horrible URL of "p=some number no one will ever remember". I receive a 404 on every page with the exception of my blogs home page.

    I have tried adding a category base and a tag base as well and still push nothing but 404's.

    Anyone else have any luck with this as of yet?

  12. uptowngal
    Member
    Posted 5 years ago #

    I tried both solutions here - i.e. "pathinfo" as well as the General settings tinkering thingy. Both didn't work for me.

    Can anyone help please?

  13. uptowngal
    Member
    Posted 5 years ago #

    Good grief! I have no idea why this is happening but I got my permalinks to HALF work.

    My permalinks (before the 2.6 nightmare) used to be in the format:
    http://uptowngal.org/blog/2008/08/19/sample-post/

    Then WP 2.6 came and they got all broken and nothing could fix it.

    After the upgrade to 2.6.1, they still didn't work. HOWEVER, by selecting a "Custom Structure" in my permalinks setting page and using:
    /index.php/%year%/%monthnum%/%day%/%postname%/

    I now get this:
    http://uptowngal.org/blog/index.php/2008/08/19/if-i-could-take-a-pic/

    So I get my post name as part of the URL, but there's this "index.php" there. Anyone knows why?!?!??

  14. magius2244
    Member
    Posted 5 years ago #

    @uptowngal

    I believe "index.php" is inserted into the permalink due to an IIS issue due to its lack of the mod_rewrite function.

    There is a post on it here:

    FIX: 2.6 Permalink issues with "index.php

    Hope that helps...

    Note: That article did not solve my permalink issues described further up in this post.

  15. magius2244
    Member
    Posted 5 years ago #

    Re-tried all steps this morning...no dice. Anyone have any ideas?

  16. Kansas Wheat
    Member
    Posted 5 years ago #

    We've spent HOURS on the permalink issue as well. Went from (I think) 2.1 to 2.6 and lost categories as well as permalinks. As long as we used the default link structure, it was OK. (rebuilt the categories to fix)

    We also had a new RSS feed address (old one involved index.php, new one didn't). RSS feed issue was fixed when we upgraded to 2.6.1 yesterday.

    We've tried EVERY recommended solution for the permalinks. Finally found one that worked:
    index.php/%year%/%monthnum%/%day%/%postname%/

    We're running Apache.

    If you have a blog at index.php on Apache, definitely try the index.php custom path.

    Thanks all for the help...

    (edited to clarify upgrade to 2.6.1)

  17. dsamorano
    Member
    Posted 5 years ago #

    I'm having a issue with the Perma links too, running on a windows server. 2.5 worked fine. Upgraded to 2.6 did the workaround of the entering tags, and that worked.

    I installed 2.6.1 on a new domain before upgrading my other ones and the workaround for the tags does not work..

    Anyone have a solution?

  18. MasterCIW
    Member
    Posted 5 years ago #

    This is very frustrating I know. I had 2 wordpress installations on the same IIS server. I upgraded both of them to 2.6. 1 worked perfectly, the other randomly gave 404.

    The good news is 2.6.1 fixed my problem blog, but before the fix what worked for me was adding an extra category in the string. For example instead of index.php/%postname%/ I had to put something like frustrating/index.php/%postname%/ - and for some reason that worked, I don't like the extra "directory" it puts in there, but atleast it got rid of the 404s.

  19. royfossblog
    Member
    Posted 5 years ago #

    None of the above mentioned fixes or alternate Permalink format works for me either unfortunately. Im wondering if I should just go back go 2.5 and be happy, why did I fix something that wasn't broke? :(

  20. dsamorano
    Member
    Posted 5 years ago #

    I want to go back to at least 2.6 with the category base and tag base at least worked...

  21. dsamorano
    Member
    Posted 5 years ago #

    So far after setting permalinks...they seem to work as long as the site loads in as http://www.domain.com/index.php, but the landing page is just http://www.domain.com which generates the 404 message.

    Knowing that some programmer can come up witha afix I'm sure... WordPress is not redirecting the site to http://www.domain.com/index.php when just the http://www.domain.com is loaded...

    Someone please fix this issue.... Now I know whay I didn't upgrade from 2.1 for a long time...this is messed up.....for us on IIS servers...

  22. jojoma
    Member
    Posted 5 years ago #

    Too bad this issue was fixed with 2.6.1. The link with p_id= has really caused me a lot of problems.

  23. wiselywoven
    Member
    Posted 5 years ago #

    this permalink issue is killing me! even with 2.6.1

  24. wiselywoven
    Member
    Posted 5 years ago #

    Okay, this may not work for everyone but it worked for me. I updated to version 2.6.1. The permalinks were still broken like before. Everything was still 404ing- posts and pages alike.

    I was manually changing my .htaccess file in the wp-admin folder after upgrading because it was not writable whenever I tried to update my permalink structure from the WordPress dashboard.

    I changed my whole blog directory (the folder)to a 777 permission within my web host account utility (WebShell). I then changed the permalink structure as before, and WordPress was able to write to the .htaccess file at that point.

    I then changed my blog directory back to a 755 permission (don't leave your permissions at 777! you'll be hacker bait if you do).

    All my permalink nightmares dissolved in the dawn of my last desperate effort to understand the relationship between permalinks, permissions and the .htaccess file.

    I hope that helps for at least one other person.

  25. magius2244
    Member
    Posted 5 years ago #

    @ jojoma

    Too bad this issue was fixed with 2.6.1. The link with p_id= has really caused me a lot of problems.

    You must have lucked out with something then...I can't even get the 2.6 workarounds to function with fresh installs on 2.6.1

  26. magius2244
    Member
    Posted 5 years ago #

    @ wiselywoven

    I changed my whole blog directory (the folder)to a 777 permission within my web host account utility (WebShell). I then changed the permalink structure as before, and WordPress was able to write to the .htaccess file at that point.

    I then changed my blog directory back to a 755 permission (don't leave your permissions at 777! you'll be hacker bait if you do).

    Unfortunately, my host doesn't allow the .htaccess file. I tried to change my IIS permissions on the root (temporarily) and adjust my permalinks and didn't have any luck...It was worth the shot though...

    Any other suggestions out there?

  27. royfossblog
    Member
    Posted 5 years ago #

    Still having a problem with Permalinks on IIS. Is this topic being ignored or acknowledged by anyone? This is with a fresh install of 2.6.1

  28. gillesenvrac
    Member
    Posted 5 years ago #

    I installed 2.6.0 to replace my 2.1 installation, and had quite a problem with my categories... that I managed to correct with the help of this forum. I also had the problem of the permalink (I am on a Linux server) so I had to let the default manner until a solution is found. I did not want to risk another night of labor (upgrading to 2.6.1) without being confident that the permalink will be corrected.

    So I was glad to try the solution of wiselywoven and to see that it works. After making temporarily my blog directory '777', I was able to change the permalink from the default to "almost" what it was : index.php/year/month/day/postname.

    The index.php was not there before : it is not just a question of having a "cute" or more lisible URL, the worst problem is that all the links that are... linking to pages of my blog, all the content of the caches of Google, will all give an error.

    If I have correctly understood, the index.php on the permalink is still there, under 2.6.1, is it ? If so, I will have to wait... But this problem is a serious break in the web of links between blogs, search engines...

  29. magius2244
    Member
    Posted 5 years ago #

    @ gillesenvrac

    If I have correctly understood, the index.php on the permalink is still there, under 2.6.1, is it ? If so, I will have to wait... But this problem is a serious break in the web of links between blogs, search engines...

    I think the "index.php" prefix is just for IIS servers if I am not mistaken.

    I found this on another post about the permalink issue from 2.6:

    If you're using Linux/Apache on your webserver, you don't really need the index.php anyway. Try removing it. The index.php thing was only meant for IIS servers, which don't support mod_rewrite.

    I am a little baffled as to what WAS fixed with this issue for IIS users that the release notes mentioned. So far the only change I see is that the 2.6 workaround doesn't work AND the problem still exits.

    I have 5 clients that want WP blogs integrated into their websites on IIS servers. All of them want SEO. This default permalink structure of p=whatever is going to tank that.

    I sincerely hope that some solution or workaround can be found.

    Any new thoughts out there on this issue?

  30. royfossblog
    Member
    Posted 5 years ago #

    Hey Guys We're still needing some kind of solution here... Is there absolutely no work around yet for IIS users? This is getting frustrating and I'm waiting patiently for a fix :(

Topic Closed

This topic has been closed to new replies.

About this Topic