WordPress.org

Ready to get started?Download WordPress

Forums

permalinks: I can't find where to edit them (11 posts)

  1. carimoves
    Member
    Posted 1 year ago #

    I'm not sure if I'm blind, but I can't find where to edit my permalink structure. I can find a lot of information on how to edit permalinks, but each demo shows that permalinks are accessible by going to Dashboard > Settings > Permalinks. Every picture shows "Permalinks" listed as an option, but I very clearly do not have that as an option on my side bar.

    Any advice? If it is important, I am not sure what version of WordPress I am using.

    All my love and gratitude for your assistance!

  2. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Did you try as per instructions here?
    http://codex.wordpress.org/Settings_Permalinks_Screen

  3. carimoves
    Member
    Posted 1 year ago #

    Thanks for the response! Sadly, yes, I have tried the instructions there -- but my side bar does not look like that.

  4. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    but I very clearly do not have that as an option on my side bar.

    You have to set your permalinks options from your dashboard, not your sidebar. Did you try setting permalinks from your dashboard?

  5. carimoves
    Member
    Posted 1 year ago #

    Yes. Under the "Settings" on the Dashboard, I have the following options:

    General
    Writing
    Reading
    Discussion
    Media
    Sharing
    Polls
    Ratings
    Email Post Changes
    Open ID
    Webhooks

    None of these allow me to access permalinks.

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    Are you sure you are logged in as an admin user?

  7. carimoves
    Member
    Posted 1 year ago #

    I only have one log in for the blog I have created and maintain. So unless there's another way to login as an admin, yes.

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    Using Phpmyadmin (or another MySQL management tool), first backup your database. Then navigate to your wp_usermeta table and locate the meta_key called "wp_capabilities" for your user_id. Change the meta-value for this record to:

    a:1:{s:13:"administrator";s:1:"1";}

  9. ClaytonJames
    Member
    Posted 1 year ago #

    Also, the next time you log in, you might try accessing - yoursite.com/wp-admin/options-permalink.php - directly, to see if you get an error message.

  10. carimoves
    Member
    Posted 1 year ago #

    Using Phpmyadmin (or another MySQL management tool), first backup your database. Then navigate to your wp_usermeta table and locate the meta_key called "wp_capabilities" for your user_id. Change the meta-value for this record to:

    a:1:{s:13:"administrator";s:1:"1";}

    I guess I'm going to have to get one of my more tech-savvy friends to help, because I'm not sure how to back it up or find the wp_usermeta. But this is probably the source of my issues, so thank you!

    Also, the next time you log in, you might try accessing - yoursite.com/wp-admin/options-permalink.php - directly, to see if you get an error message.

    I was very excited, but this didn't work -- I got the error message "Sorry, this is disabled." Probably because I'm apparently not the administrator of my own blog. Is that a default? Because I'm not sure why it would happen otherwise...

  11. esmi
    Forum Moderator
    Posted 1 year ago #

    I'm not sure how to back it up or find the wp_usermeta

    It's a table within your WordPress database. Your hosts may be able to help you access the database.

    Is that a default?

    No but there are a number of reasons why you might see this message - only one being the fact that you are not logged in as a full admin of the site.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags