WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks - Gone for Good (8 posts)

  1. mikules
    Member
    Posted 2 years ago #

    I've tried everything under the sun, nothing after nothing. Google after Google-- and the content on it is so old, I don't think it will help my problem.

    When I'm in my WP dashboard and click on Settings>>Permalinks, I get this:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@XXXXXX.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I have deleted my .htaccess files.
    I have added the code suggested by WordPress's Permalinks page in my .htaccess
    I have reinstalled Apache
    I have restarted the server

    Seriously, they should just take Permalinks off the menu in Wordpres. It doesn't work.

  2. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    It does work and is used widely. It does require some specific server setup for those like you who run their own servers.

    Apache web server with the mod_rewrite module

    Microsoft IIS 7+ web server with the URL Rewrite 1.1+ module and PHP 5 running as FastCGI

    Microsoft IIS 6+ using ASAPI_Rewrite

    Lighttpd using a 404 handler or mod_rewrite (see See Also)

  3. Veronica
    Member
    Posted 2 years ago #

    Just in case this is the basic code you need to have in the .htaccess file:

    # Do not remove this line, otherwise mod_rewrite rules will stop working
    RewriteBase /
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Now make sure the permissions of that file is set to 666, then try cleaning the cache folder or use a pligin for that, also clean the temp files of your computer and try again.
    Once i got a 404 error too after i instaled a plugin that rewrote in my .htaccess file, maybe you have plugin conflict if the first solution i wrote doest work try deactivating your plugins and try again. Hope it helps

    Veronica

  4. mikules
    Member
    Posted 2 years ago #

    mod_rewrite module is installed

    Used Mvburgos's snip above.

    Does not work.

    turned off all plugins, still doesn't work.

  5. mikules
    Member
    Posted 2 years ago #

    I assume:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    goes in the wp-admin, but I've tried both root and wp-admin. It simply doesn't work.

    tried the 666 CHMOD, too.

    Thanks to this crap, I can't get my site indexed properly.

  6. mikules
    Member
    Posted 2 years ago #

    clearing out both .htaccess's

    Now I don't get the error from Settings>>Permalinks, now it shows my website theme.

    takes me to this url (xxxx is site name)
    http://www.XXXXX.com/wp-admin/options-permalink.php/

    and nothing happens.

    Seriously, how can WordPress not work around this type of garbage...

  7. mikules
    Member
    Posted 2 years ago #

    yep, checked again. Not a single blog post I have is being picked up by Google.

    Thanks WordPress for killing my Permalink feature WITHIN your own CMS tool. Now that it's broke, I will never get indexed.

  8. Veronica
    Member
    Posted 2 years ago #

    make sure in Settings>>Privacy you have activated the option I would like my site to be visible to everyone, including search engines (like Google, Bing, Technorati) and archivers also you can change the crawling rate by login in webmaster tools for google adding your site once you set it up clic in your site's link and go to information of your site in control panel>>Configuration then you will see crawl rate option just pick the second option and slide it to faster, save changes and thats it works for mein 24 hours or less, because normally takes 3 days or more in crawl

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.