WordPress.org

Ready to get started?Download WordPress

Forums

WP Find Your Nearest
[resolved] Permalinks giving 404 error on individual pages (12 posts)

  1. joshuajohnson
    Member
    Posted 1 year ago #

    If I set the permalinks on a site I am working on to the default setting and view one of the individual pages within the 'Find your nearest' post type, everything is fine.

    However the permalink structure I need to use is "/%category%/%postname%/" - which causes a 404 error when you try and view an individual page. The same happens if I set the permalink structure to the 'postname' setting.

    Any ideas?

    http://wordpress.org/plugins/wp-find-your-nearest/

  2. Michelle
    Member
    Posted 1 year ago #

    Same here - I have the Premium version. Really need individual FYN posts to display with the pretty permalinks, any ideas on how to make this work? Thanks!!

  3. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Please note that these forums only support free versions of plugins/themes - for help with commercial versions, please use the developer's dedicated support or contact info.

  4. Michelle
    Member
    Posted 1 year ago #

    This is part of the core functionality of both the free and paid versions, I believe. I just mentioned I had premium because I thought it might help with the debugging.

    I've been able to get pretty permalinks working in a limited way by commenting out line 27 of /includes/setup.php in the plugin:

    'query_var' => 'find_your_nearest',

    Then re-saving on the Settings > Permalinks page.

    HOWEVER, if you do this and have "Build item URL with Category" set in the plugin settings, you *must* have at least one category set per FYN post or they'll all 404.

  5. I'm glad you clarified that but as a "premium" user have been in contact with the author on his own site?

    If you visit his blog there is a contact link and I'm sure the author would like to hear about this problem.

  6. Michelle
    Member
    Posted 1 year ago #

    I've emailed him. :)

    BUT all for naught as now I think the whole thing can be fixed by a lot of resaving the permalinks... you just have to re-save globally any time you change any settings within the plugin. I think he needs to add flushing permalinks to his settings page or something.

  7. joshuajohnson
    Member
    Posted 1 year ago #

    Hmmm, resaving my permalink structure doesn't rectify the issue for me.

  8. charlesalder
    Member
    Posted 1 year ago #

    Team

    Try and deactivate the plugin, change permalinks, save new permalinks, put in pretty permalinks then reactivate plugin.

    I know I lost the pretty links as well, I think this is what I did

  9. joshuajohnson
    Member
    Posted 1 year ago #

    That still doesn't seem to do anything :/

  10. sock2me
    Member
    Posted 7 months ago #

    I'm not having any luck with these tricks either. Still getting 404 errors on all my result page links. Sent developer an email since I did purchase the Premium version....

  11. Adam Sargant
    Member
    Plugin Author

    Posted 7 months ago #

    Hi Shelly

    I sent you an email on the 9th requesting replication steps as the current set up on your development server is working for me

  12. Adam Sargant
    Member
    Plugin Author

    Posted 6 months ago #

    For future reference, the standard version, while it does use custom posts to store the FYN item data (location etc) it does *not* link through to the post from the results. It is intended to return a list of results only, not link to the posts. So permalink structure is not supported in the standard version. Support with the premium version is via email.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags