WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks for multisite (22 posts)

  1. karyignite
    Member
    Posted 5 months ago #

    Hello, I have several sites on a multisite network.

    My root site is http://www.ignitecreative.tv

    The permalinks for one of my sites works perfectly.
    http://www.igniterising.com

    However for http://www.kundaliniyogacollective.co.uk all my permalinks are showing up as http://ignitecreative.tv/kundaliniyogacollective/

    Permalinks for this site http://www.fairtunes.org all work perfectly - except in the footer which I altered the most recently.

    I have set all my domains up in the same way. The directory structure in my control panels appears to be the same.

    Could it be a theme problem?

    I am fairly new to WordPress, so please kid gloves!

    Thank you :)

  2. Do you have custom menu links? If I go to http://www.kundaliniyogacollective.co.uk/about-us/ it works fine, so it seems to be a front-end glitch.

    You're using the Domain Mapping plugin right?

  3. karyignite
    Member
    Posted 5 months ago #

    Thank you for your response Patrick.

    /aboutus doesn't work for me! Tried PC & Mac

    I am using WordPress MU Domain Mapping plugin

    I don't have custom menu links. I could try that as a cheat perhaps!

    Thanks, Kary

  4. karyignite
    Member
    Posted 5 months ago #

    No.. a custom menu link to http://www.kundaliniyogacollective/about-us/

    doesn't work. Returns a 404

  5. It worked fine a day ago when I wrote that :)

    Now, it returns a hosting like this. Did you un-map the domain?

  6. http://www.kundaliniyogacollective.co.uk/about-us/ is correct for me...

    The menu is http://ignitecreative.tv/kundaliniyogacollective/about-us/ though. How did you add the menu link?

  7. karyignite
    Member
    Posted 5 months ago #

    yes - it's the permalink structure that does't work. the mapping is fine.. that url only works if typed in directly, not from nav

    I just added my page to the custom menu, nothing fancy

  8. karyignite
    Member
    Posted 5 months ago #

    I dont think it has anything to do with the way i've set up the front end.. there's nothing to change. menu is set up correctly. mapping works. links work... stuck! :(!

  9. Bumps deleted. Don't do that, we're all volunteers with jobs and lives and such. If you can't be patient, you're going to have a bad time.

    I just added my page to the custom menu, nothing fancy

    Delete the page and re-add it now that you've added in mapping.

  10. karyignite
    Member
    Posted 5 months ago #

    Hi Mika, what bumps did you delete? I didn't post any. I have nothing but appreciation for assistance given.

  11. karyignite
    Member
    Posted 5 months ago #

    'you're going to have a bad time' is a little bit disconcerting.

    regardless

    i have tried deleting and adding my menu again

    the mapping was always in place

    i think it may have something to do with the htaccess doc but not sure how to change it.

    on multisite there is no option to open htaccess on the menu. i've tried changing it via my control panel too.

  12. "any thoughts please? :(" was deleted. You posting here multiple times is a hassle for us.

    1) If you post while we're replying, things get muddled

    2) It doesn't get anyone to help you any faster.

    Make ONE post. Wait. If you have NEW information, that's okay, but posting twice within 5 minutes? Just post one answer please :) You can edit posts for up to an hour.

    If YOU cannot be patient with free help, YOU will have a bad time because we'll stop helping you.

    i think it may have something to do with the htaccess doc but not sure how to change it.

    Why?

    http://www.kundaliniyogacollective.co.uk/about-us/ loads just fine. That means .htaccess is fine.

    https://cloudup.com/clEqFX6a388 See?

  13. karyignite
    Member
    Posted 5 months ago #

    Yes http://www.kundaliniyogacollective.co.uk/about-us/ works fine. If you go directly from the link but not from the menu.

    It's not my permalinks, I have deleted and re set up my menu, its not the htaccess, its not the directory structure in control panel..

  14. What you need to do.

    Go to http://www.kundaliniyogacollective.co.uk/

    Log in to the admin.

    Make a BRAND NEW menu with only ONE link. Make it the about page. Apply it to that location on your theme.

    Is that working?

  15. karyignite
    Member
    Posted 5 months ago #

    No, it doesn't.

    My permalink structure is not allowing anything other than the root site to show.

    The permalink options look like this
    Default http://ignitecreative.tv/kundaliniyogacollective/?p=123
    etc...

    My other sites in my network work ok and are set up the same. Except for in http://www.fairtunes.org the footer also has that problem.

    I've left the menu set up with just about

  16. Wait, your MAIN site can't use pretty permalinks? That's an absolute must for multisite.

    But you say the other sites in the network work,so what did you do differently here? It sounds like you made a mistake in some setup step.

  17. karyignite
    Member
    Posted 5 months ago #

    My root site works perfectly.

    I didn't do anything differently. All are the same set up.

    Posted 5 days ago #
    My root site is http://www.ignitecreative.tv

    The permalinks for one of my sites works perfectly.
    http://www.igniterising.com

    However for http://www.kundaliniyogacollective.co.uk all my permalinks are showing up as http://ignitecreative.tv/kundaliniyogacollective/

    Permalinks for this site http://www.fairtunes.org all work perfectly - except in the footer which I altered the most recently.

  18. You're REALLY confusing me with the back and forth about what does and does not work, so please bear with me asking things I KNOW you've answered, but do answer them as asked this time :) I'm keeping them simple for a reason here.

    1) Do pretty permalinks work on http://www.ignitecreative.tv ? You don't have any posts there so I can't actually tell...

    2) Did you set up a no-blog redirect in wp-config? http://www.ignitecreative.tv/dsfsdfdsfs redirects me to http://www.ignitecreative.tv which IMPLIES you set one up, but I'm not sure.

    3) When you set up http://www.kundaliniyogacollective.co.uk/ with domain mapping, did you make it the primary URL for that site?

  19. karyignite
    Member
    Posted 5 months ago #

    1) Do pretty permalinks work on http://www.ignitecreative.tv ? You don't have any posts there so I can't actually tell...

    yes they work fine

    2) Did you set up a no-blog redirect in wp-config? http://www.ignitecreative.tv/dsfsdfdsfs redirects me to http://www.ignitecreative.tv which IMPLIES you set one up, but I'm not sure

    not as far as i remember or aware. it wasn't me who set up the multisite - but he also does not think so

    3) When you set up http://www.kundaliniyogacollective.co.uk/ with domain mapping, did you make it the primary URL for that site?

    Yes its set up as primary

    tk u

  20. Open up the wp-config.php file.

    What do you have in the Multisite section?

  21. karyignite
    Member
    Posted 5 months ago #

    Tk u

    /* Multisite */
    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'ignitecreative.tv');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'ignitecreative.tv');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Enable or disable Worpress Multi-site features **/
    define('WP_ALLOW_MULTISITE', true);
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    define( 'SUNRISE', 'on' );
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
  22. Do you REALLY have everything in there twice?

    It should be this:

    /* Multisite */
    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'ignitecreative.tv');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    
    define( 'SUNRISE', 'on' );
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    Also? DO NOT put anythgin below the line that says to stop editing :) I mean, what I put there for you is fine, but you had SUNRISE down there, and that jacks things up/

Reply

You must log in to post.

About this Topic