WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks don't work (6 posts)

  1. carltown
    Member
    Posted 9 years ago #

    I've read all the codex support on this, modified my permalinks structure to get good SEO, edited the .htaccess file as requested (created it in the www directory), and then found none of the linking worked for any archive item etc. on my wordpress. I backed my changes all out and it works with the 'ol ?p=27 or whatever, but this probably won't give the the SEO I want.

    Once the permalinks template is changed, do I need to do anything to get my blog links working again? Does this permalink change also affect trackbacks? They aren't working beyond ?p=27 either.

    This is for 1.5 according to my readme file. I've downloaded a fresh zip, but the readme still says 1.5. I haven't installed the fresh version yet.

  2. moshu
    Member
    Posted 9 years ago #

    "Nice" permalinks have nothing to do with search engines - they are more for the human eyes :)
    If you have your WP installed in a subdirectory, your .htaccess should be in that folder. You don't have to edit it, if it's writable WP will take care of updating the rules based on the tags you entered in your permalinks option panel.

    Edit. Probably the readme file wasn't updated. The download is the latest: 1.5.1.2.

  3. skippy
    Member
    Posted 9 years ago #

    Using Permalinks includes some troubleshootnig steps. You claim to have read all the Codex support for permalinks -- did you follow the troubleshooting steps?

  4. carltown
    Member
    Posted 9 years ago #

    Oops - no thanks for that tip. I'm trying to stick with the codex as much as possible - saves time and minimizes support.

  5. skippy
    Member
    Posted 9 years ago #

    And we're trying to direct as many support questions toward the Codex, as appropriate!

    If you find that the Codex does not answer your question, or if the Codex is in any way deficient, please help us improve it!

  6. carltown
    Member
    Posted 9 years ago #

    Thanks Moshu - putting .htaccess in the right directory did the trick.

Topic Closed

This topic has been closed to new replies.

About this Topic