WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalinks changes header (12 posts)

  1. aydos90
    Member
    Posted 3 years ago #

    Hi,

    I have done a search and found a similar post but it didn't fix my problem.

    When I change my permalinks to "pretty" permalinks for example:
    /%category%/%postname%/%post_id%/

    It breaks the header on every page other than the home page (the home page is what every page should look like and does when I use default permalinks).

    My website is:
    http://www.adanaspland.com

    Header code is available here:
    http://wordpress.pastebin.com/8kM36AL6

    I hope that is all the information you require, cheers guys.

  2. Tara
    Member
    Posted 3 years ago #

    try:

    -deactivating ALL plugins temporarily to narrow down and possibly fix the problem. If the problem goes away, activate them individually to find the culprit.

    -switching to the default theme ("twentyten") for a moment by renaming your current theme's folder in wp-content/themes. The idea is to force WordPress to fall back to the default theme to rule out any theme-specific issue.

  3. aydos90
    Member
    Posted 3 years ago #

    Hi t-p,

    Thank you for your prompt response.

    Unfortunately, deactivating all the plugins didn't work.

    Went in and renamed my current theme so it would switch back to the default theme ("twentyten") as you instructed it did this.

    Link to my site: http://www.adanaspland.com

    My little logo header which was dropping off on other pages when using "pretty" permalinks has now completely ran away.

    So would that mean it is not necessarily theme related but my dodgy attempt at code in the header.php?

    Should i switch back to previous theme so people can see the issue?

  4. Tara
    Member
    Posted 3 years ago #

    My little logo header which was dropping off on other pages when using "pretty" permalinks has now completely ran away.

    I am not sure if i follow you.

    As I see, your header looks normal, then beneath your post title there is "Open" logo which looks normal.

  5. aydos90
    Member
    Posted 3 years ago #

    Sorry I have taken the site back to where we started I'll try and explain it again.

    If you have a look at:
    http://www.adanaspland.com

    Now if you have a look at this page:
    http://www.adanaspland.com/about

    See the difference? The header image has been replaced with text, if I use the default permalinks it is fine. It only switches back to text if I change to "pretty" permalinks which I am currently using.

    Thank you for your continued help and patience.

  6. Tara
    Member
    Posted 3 years ago #

    Try re-saving your permalink structure at Admin panel>>>Settings>>>Permalinks. WordPress either creates/amends the .htaccess file for you or provides you with the correct block of code to manually add to your .htaccess file.

    Codex Guide: http://codex.wordpress.org/Using_Permalinks

  7. aydos90
    Member
    Posted 3 years ago #

    Taken from the link you gave me in the Codex Guide:

    Where's my .htaccess file?

    WordPress's index.php and .htaccess files should be together in the directory indicated by the Blog address (URI) setting on your General Options page. Since the name of the file begins with a dot, the file may not be visible through an FTP client unless you change the preferences of the FTP tool to show all files, including the hidden files. Some hosts (e.g. Godaddy) may not show or allow you to edit .htaccess if you install WordPress through the Godaddy Hosting Connection installation.

    My host is Godaddy so I assume this could be the problem fixing it is another thing... This is what my .htaccess file looks like:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  8. Tara
    Member
    Posted 3 years ago #

    try contacting Godaddy.

  9. aydos90
    Member
    Posted 3 years ago #

    I sent the below email to Godaddy support. I don't like my chances of them being able to help but perhaps they have been made aware of the problem previously and hopefully have an answer.

    Hi,

    When I change my permalinks to "pretty" permalinks for example if i use:
    /%category%/%postname%/%post_id%/

    It breaks the header image on every page other than the home page.

    So, If you have a look at:
    http://www.adanaspland.com

    Now if you have a look at this page:
    http://www.adanaspland.com/about

    See the difference? The header image has been replaced with text, if I use the default permalinks it is fine. It only switches back to text if I change to "pretty" permalinks which I am currently using.

    My header code is available at:

    http://wordpress.pastebin.com/8kM36AL6

    I have attempted deactivating all plugins to try and fix the problem.
    Also have tried switching to the default theme ("twentyten"). No such luck.

    I believe perhaps it is something to do with the .htaccess file

  10. aydos90
    Member
    Posted 3 years ago #

    I may have found a solution... Testing.

    Please note, however, that our installation offers limited scope for modification, the addition of new modules, etc. You may need to remove our installation, and then re-install it manually into your hosting account - this will allow a greater degree of flexibility with regard to changing the application. However, please note that we are not able to assist with this process, or any subsequent troubleshooting of this independent installation which may be required.

    If what I am doing doesn't work I wonder if what they have suggested will.

  11. aydos90
    Member
    Posted 3 years ago #

    WOOHOO! Seems I didn't search hard enough eventually found a solution posted by moshu /iridax.... 2 years ago.

    Anyone who finds this make sure you do the following in your header code:

    <img src="<?php bloginfo('template_url'); ?>/images/my-pic.jpg" alt="" />

    You don't upload theme images in the uploads. You keep them in the theme folder, under /images. Most themes have such a subfolder. And then the solution offered by iridiax works perfectly.

  12. Tara
    Member
    Posted 3 years ago #

    Glad you got it sorted. :-)

Topic Closed

This topic has been closed to new replies.

About this Topic