WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalinks Causing Problems (6 posts)

  1. VirtualityStudio
    Member
    Posted 1 year ago #

    Pretty permalinks is not working on my site. It returns a 404 error for all single pages, and a function.preg-match error on the blog. The function error appeared after updating WP-ecommerce plugin today... which I need, so I can't just turn it off. I have been ripping my hair out all morning trying to find the source of the single post page issue, but haven't found it.

    Any ideas about how to fix this? Right now I have it on default settings and those problems go away. That of course causes a whole host of other problems though... Switching to default and back doesn't work. VERY frustrating!

    Site is liskabora.com

  2. Epro
    Member
    Posted 1 year ago #

    Is this on a localhost? turn the rewrite_module on for Apache, and you're gold

  3. VirtualityStudio
    Member
    Posted 1 year ago #

    No - it is hosted on godaddy. :/

  4. VirtualityStudio
    Member
    Posted 1 year ago #

    Here is the htaccess file contents:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    It is inside of a subdomain folder... could that be causing the problem?

  5. Epro
    Member
    Posted 1 year ago #

  6. VirtualityStudio
    Member
    Posted 1 year ago #

    You are AWESOME! Between that and deactivating a wp-ecommerce add-on plugin I am back up and running again!

    Thank you!!!!!!!!!!

Topic Closed

This topic has been closed to new replies.

About this Topic