WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalinks cause "Page not Found" (10 posts)

  1. Jordan
    Member
    Posted 8 years ago #

    Okay, so I've read the other permalink threads and I'm pretty sure this is not the same issue.

    Everything seems dandy. I'm not using Apache 1.3.33. I'm using WordPress 1.5. I went into permalinks and used the

    "/archives/%post_id%" option

    I clicked "Update" and it said that my permalinks had been updated. But when I go to my site and click on a link, it says page not found.

    I tried it with

    "/%year%/%post_id%"

    ... still no dice. Any ideas what might be going on here? Seems like WordPress is doing everything right except letting me see the pages!

  2. James
    Happiness Engineer
    Posted 8 years ago #

    Your permalink rule needs a closing slash. For example, use either /archives/%post_id%/ or /%year%/%post_id%/ . If that doesn't work, check the .htaccess file in the main WordPress directory and see if any WordPress-related rewrite rules were added to it.

  3. Jordan
    Member
    Posted 8 years ago #

    Tried it with the closing slash, and I still get the same problem.

    Also checked to make sure that AllowOverride is enabled (it is).

    The .htaccess file seems fully propogated with rules.

    Any other ideas? :-\

  4. IOOI
    Member
    Posted 8 years ago #

    Hi,

    I have the same problem, no matter what pattern I use, all links to stroies, pages, categories.. are all broken, but the admin-functions are OK.

    I created the weblog on Win2K, importing all databases and files from another machine WinXP, which workes fine..

    what's the matter ??

  5. moshu
    Member
    Posted 8 years ago #

    Did you read the part about being on a Win server? Using_Permalinks

  6. Jordan
    Member
    Posted 8 years ago #

    Well, I'm on a Linux server :-\

  7. vkaryl
    Member
    Posted 8 years ago #

    There are some major usability differences between win2k and winXP. I don't honestly know what they are or how to fix them, I have winXP which works perfectly but have a friend with win2k who's never been able to get permalinks to work.

    So while I can't help you, for which I apologize, I do know you aren't alone. If you figure it out, please post what you did so I can help out my friend.

  8. IOOI
    Member
    Posted 8 years ago #

    i will if i can figure it out :)

  9. IOOI
    Member
    Posted 8 years ago #

    hey, I got it! :D

    I once created weblog using Drupal, and set the AllowOverride directory to drupal. When I changed to WP, I forgot to change the directory name, and it's the reason...

    so make sure your httpd.conf set correct like:

    <Directory "F:\www\wordpress">
    Options Indexes FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>

    hope this helps!

    IOOI

  10. StruanKing
    Member
    Posted 8 years ago #

    You may also wish to try one of these.

    *nix server:
    - from my experience wordpress looks in its root folder for the .htaccess file i.e yoursite.com/blog means you need one in the blog folder.
    - create an empty text file and call it exactly ".htaccess" not ".htaccess.txt" or anything.
    - give permissions for world read\write\execute (777 i think) - this only temporary
    - in WordPress admin set the permalink as you wish and update
    - refresh your main page and test a link
    - reset the file permission
    - refresh and test a link again

    Windows:
    - try creating a php.ini file at your site root with just these lines in it

    cgi.fix_pathinfo = 1
    cgi.force_redirect = 0

    Hope that helps

Topic Closed

This topic has been closed to new replies.

About this Topic