WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalinks broken after moving to same location, same URL, different system (3 posts)

  1. antoniowp
    Member
    Posted 1 year ago #

    I have moved my local development wp from ubuntu 13 to kubuntu 13, same location, same URL. I have just copied files to target /var/www and ensured permissions and ownership are ok. The same with database.

    The front page loads normally but I am unable to load posts and pages: 404 error.

    wp_options is ok (userdir, home): http://localhost/mywp

    .httaccess seems to be ok: I have tried several times to let wp write permalink rules:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /mywp/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /mywp/index.php [L]
    </IfModule>
    
    # END WordPress

    Even tried adding at the beginning:

    <Directory />
        Options FollowSymLinks
        AllowOverride All
     </Directory>

    /etc/apache2/conf also has:

    <Directory />
        Options FollowSymLinks
        AllowOverride All
     </Directory>

    mod_rewrite is activated.

    Posts are loaded using short links, I think the problem is permalinks but at this point I have no idea what the problem is. Probably I will have to start again from the beginning, even uninstalling LAMP. BTW, Apache is running very slow.

    I would appreciate your support.

  2. Tara
    Member
    Posted 1 year ago #

    -Try resetting your custom permalinks back to the default setting and renaming your WordPress .htaccess file. If that works, then try reading Using_Permalinks before setting a custom permalink structure again.
    If clearing your Permalinks does not alleviate the issue, this could be attributed to anything from a web server configuration to a bad WordPress install.

  3. antoniowp
    Member
    Posted 1 year ago #

    Problem solved here.

    We need to change AllowOverride None to AllowOverride All in two places.

    Not in file /etc/apache2/apache2.conf, but /etc/apache2/sites-available/default instead.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic