WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalinks broken after blog move (7 posts)

  1. ladylynn
    Member
    Posted 5 years ago #

    I upgraded to 2.6 two days ago, and it seemed to go well. I didn't notice any problems, anyway. Then yesterday, I moved my blog from it's old spot at lynndaniels.com/blog to lynndaniels.com, carefully following the procedure outlined in Moving WordPress Within Your Site, and changed themes. After I did that, my permalinks quit working. My front page works, but all the links produce a 404 Not Found error. I've tried the temporary fixes outlined in this sticky post -- fix #1 broke my theme (Revolution), and fix #2 did nothing. I'm not an advanced user, so I didn't even attempt fix #3.

    I'm kind of at a loss for things to do, and searching the forums into the wee hours last night turned up nothing for me. If anybody has ideas for things I might try, I'd be really grateful.

    Thanks in advance!

  2. moshu
    Member
    Posted 5 years ago #

    The most obvious thing to try is to reset the permalinks settings in your admin panel. Did you do that?

  3. ladylynn
    Member
    Posted 5 years ago #

    I did. I changed it to the default setting, saved it, then changed to to my custom setting and saved it. Still broken. I also tried adding the "category" and "tags" as suggested in the sticky post I linked in my OP, but that didn't do anything. I just talk to my webhost, and they're going to try reinstating my mod-rewrite rules and see if that does the trick.

  4. moshu
    Member
    Posted 5 years ago #

    Just to make sure we covered everything:
    - was the htaccess file moved, too?
    - is it writable?
    - can you check if the rewrite rules in it still contain /blog/?

  5. ladylynn
    Member
    Posted 5 years ago #

    htaccess was moved. I just checked, permissions were set 0644. I changed them to 0777 (do I need to go that far, or could it be less?). I just opened the file, and all that's in there is mod security.

    (Thanks so much for going over this with me!)

  6. moshu
    Member
    Posted 5 years ago #

    Here we go! You don't have the WP-specific rewrite rules in the .ghtaccess file!
    It won't work if you don't have something like this in it:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    N.B. In the previous location it had to have /blog/ added to the RewriteBase and RewriteRule lines...

  7. ladylynn
    Member
    Posted 5 years ago #

    WOO HOO! That did it. You're my hero, moshu. Thanks so much.

Topic Closed

This topic has been closed to new replies.

About this Topic