WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks Broken (9 posts)

  1. milesbb
    Member
    Posted 7 years ago #

    Hi if I choose a permalink option other than the default one then the posts show up fine on the index but when I click them the links are broken. help pleas

  2. Janzomaster
    Member
    Posted 7 years ago #

    Hm. You can still access the posts if you enter the default ?p=ID manually...
    What exactly did you change? Check http://codex.wordpress.org/Using_Permalinks especially the part about the mod_rewrite and .htaccess file

  3. milesbb
    Member
    Posted 7 years ago #

    just changed the custom option. none of the htaccess

  4. milesbb
    Member
    Posted 7 years ago #

    nvm, my .htaccess just wasnt writeable. now it is so wordpress can update it

  5. djme
    Member
    Posted 6 years ago #

    My links are broken as well but not from upgrading.

    Even though I gave my .htaccess 777 permissions I still get the error?

    My .htaccess is located in the root directory under serversecure>.htaccess

    What's going on??!?!? Where should my .htaccess be located?

  6. Michael
    Member
    Posted 6 years ago #

    I am having the very same problem. My permalinks are broken. Does someone have the definitive solution regarding .htaccess, where to put it on your server, and what permissions to apply to it?

  7. djme
    Member
    Posted 6 years ago #

    I changed my permalink to;

    /index.php/%postname%/

    and like MAGIC my blog is back!!

  8. pmars
    Member
    Posted 6 years ago #

    My permalinks are broken also. I switched to real links from virtual links. I suspect that maybe the Mod_rewrite module is missing from my server

  9. Michael
    Member
    Posted 6 years ago #

    Hey guys, I actually resolved my problem with some help from another forum poster. Here are the instructions he gave me that worked for correcting my permalinks:

    .htaccess should be the files name.

    you could try to use the wp-admin section to generate one for you:

    Settings -> Permalinks -> Click "Save Changes" at the bottom of the screen. If this doesn't work, here is the code that should be in the file

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    (Don't worry, it's the same for all permalink combinations - all it really says is "if the requested url is not a physical file or directory on the server, send the request to index.php")

    .htaccess files are very tricky. The first one I ever created rendered my site useless, the code was correct, but I had used a bad text editor, that had added element to the code which I could not see. Textedit might be saving the file with formatting.

    My advice to you would be to log into your host's cpanel, vhost or plesk application and see if you can find a "File Manager". This is a piece of software that you allow you to navigate the files on your server an edit then in plain text. Please give this a try and let me know how you make out.

Topic Closed

This topic has been closed to new replies.

About this Topic