WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks blocking 1ShoppingCart's cmd.php? (4 posts)

  1. artemisian
    Member
    Posted 4 years ago #

    1ShoppingCart have a domain masking feature which allows me to use links on my domain instead of theirs for the shopping cart. It requires a cmd.php file at root level, which I've uploaded.

    However, whenever I try to go to a link involving cmd.php, instead of being redirected to the appropriate page, I just get my own WP custom 404 page.

    I'm guessing that the problem is to do with permalinks - that WP is looking for a WP page by the name of cmd.php etc, and as there isn't one, it's giving me a 404 instead.

    Does anyone have any idea how I can get round this problem? Is there any way to tell WP to check for real paths as well as permalinks?

  2. jceresini
    Member
    Posted 4 years ago #

    What does you're .htaccess file have in it? Typically the .htaccess file only redirects to the wordpress page if the file doesn't exist. Are you sure the file is in the same folder as the index.php and wp-config.php files? Can you provide a link so we can see the blog?

    [signature moderated Please read the Forum Rules]

  3. artemisian
    Member
    Posted 4 years ago #

    Hey jceresini. My .htaccess just has the usual bit of WP generated code in:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    plus Options -Indexes, and some 301 redirects of old pages.

    After a little more experimentation, I've found that I only get the 404 if the link has a query string. If I go to:

    http://mydomain.com/cmd.php

    Then it redirects to 1ShoppingCart's home page.

    If I try variations which ought to work, for example links of the form:

    http://mydomain.com/cmd.php?u=url
    http://mydomain.com/cmd.php?af=affiliate code]
    http://mydomain.com/cmd.php?productid=product code]

    Then I get my WP 404.

    If I try a made-up query string on a real WP page, such as http://mydomain.com/contact/?madeup=4893574 then I get the page I'd expect (my contact page here). So *something* is happening, but I can't figure out what. It seems unlikely that the cmd.php code is broken, as it's just 1ShoppingCart's standard code, which I've seen working perfectly on plenty of other sites. So what's going on?

  4. thelanj
    Member
    Posted 3 years ago #

    i'm having the exact same problem. did you ever find a solution?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.