WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks aren't working (16 posts)

  1. ajtatum
    Member
    Posted 4 years ago #

    I'm trying to setup WordPress on my site, http://www.fourleafit.com, but I can't get permalinks to work correctly. When I set the option to "month and name" it does modify the .htaccess for the site to the below:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    However, if I go to a "permalink page" it redirects to a 404 error. I contacted GoDaddy support and they claim that everything is setup properly on the server and that they won't help in getting this matter resolved.

    Any help on getting this matter resolved would be greatly appreciated!

    Thank you,
    Andrew

  2. anunturi
    Member
    Posted 4 years ago #

    check your .htaccess to be 777

  3. ajtatum
    Member
    Posted 4 years ago #

    Thanks for the tip, but it's already 777.

    WordPress is writing to the file successfully.

    According to GoDaddy regarding this issue:

    "Mod_rewrite is currently enabled in all shared Linux hosting accounts. The rest of the functions you have included may be enabled by using a .htaccess file. Unfortunately we cannot assist you with or coding this file."

    What they mean by the rest of the functions is that I requested they check that

    - The FollowSymLinks option enabled
    - FileInfo directives allowed (e.g. AllowOverride FileInfo or
    AllowOverride All)

    I'm not sure how to do this exactly as most of my web programming experience has been with Windows.

    I gave it a stab and changed my .htaccess file to be as follows:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    Options +FollowSymlinks
    AllowOverride All

    But, that didn't work. I still can't access any permalinks.

    This is really driving my nuts!

  4. alism
    Member
    Posted 4 years ago #

    Delete your .htaccess.
    De-activate all your plugins, in case one is interfering.
    Try resaving the Permalinks to the 'month and name' (WordPress should generate a new .htaccess).

    Any joy?

  5. ajtatum
    Member
    Posted 4 years ago #

    Thanks alism; however, it's still a no go.

    I deleted my .htaccess, deactived all my plugins (there are only four) and even set my theme to the default. I then set permalinks to month and name, which generated the below text. When I then attempted to access a page or post, I got a 404 :(

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    To note, I tried all other permalink structures and none of them work.

    So, no joy... but I appreciate your help. Any other ideas out there?

  6. alism
    Member
    Posted 4 years ago #

    Ok, try adding this to the very top of your .htaccess then:

    <Directory />
        Options FollowSymLinks
        AllowOverride All
     </Directory>
  7. Mark / t31os
    Moderator
    Posted 4 years ago #

    You'll proberly want to use + with the symlinks option..

    Options +FollowSymLinks

    Place it before the WordPress stuff though..

  8. ajtatum
    Member
    Posted 4 years ago #

    I was really hoping that it was going to work, but no go. This is what .htaccess looked like after I changed the permalink option:

    <Directory />
        Options +FollowSymLinks
        AllowOverride All
     </Directory>
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    But, still, when I go to a page or post it takes me to a 404 error.

  9. alism
    Member
    Posted 4 years ago #

    Perhaps I'm missing something really obvious here, but I'm rapidly running out of ideas.

    Can you check that the .htaccess is actually getting processed? Do you get an internal server error if you type in a load of crap at the start of the file?

  10. From http://zacvineyard.com/blog/2008/10/24/wordpress-godaddy-and-permalinks/

    All you need to fix this problem is patience. Every hour (at the top of the hour), GoDaddy refreshes .htaccess file configurations on their servers. After you select the appropriate Permalink structure you’d like your blog to have, you need to wait for GoDaddy’s servers to refresh the .htaccess file configuration. Once this happens, your permalinks (modifed URLS) should be working perfectly.

  11. alism
    Member
    Posted 4 years ago #

    Ipstenu, genius, wouldn't have got that in a million!

  12. I had this reeeeealy vague memory of someone saying goDaddy's hosting had this weird cloud effect. Google to the rescue!

    One of the commenters had a slightly different solution:

    What finally worked for me was taking the advice of one persons comment to go godaddy host centre and under “Settings” and then “404 Error Behaviour” I selected “Use Homepage” instead of “Use GoDaddy custom page”. Worked right away after that.

  13. ajtatum
    Member
    Posted 4 years ago #

    Thanks for the tip! I set the permalink's option in WordPress and went to my GoDaddy control panel and updated the 404 error handling. The links are still going to the 404 page, but it's the old 404 page... not the homepage. There's a note saying that it could take up to 30 minutes for the change to take affect.

    So, as painful as it may be, I'm going to wait an hour to see if the changes take affect. Meanwhile, I hope traffic diminishes for a bit as I really don't want people to think the site's full of dead links.

    I'll keep you updated! Thanks again!

  14. ajtatum
    Member
    Posted 4 years ago #

    I don't believe it... BUT IT NOW WORKS!!!!!

    Thank you!

  15. Go Daddy
    Go Daddy Support
    Posted 4 years ago #

    Just so everyone knows, our servers are set to no longer use .htaccess caching. These files are now picked up immediately. We're taking a look at ajtatum's specific server and will correct any issues we may find.

  16. adambundy
    Member
    Posted 4 years ago #

    @Ipstenu is a lifesaver!! I have been messing with htaccess and permalink settings, but found this post and tried accessing the godaddy control panel, going to setttings, 404 error handling, and changed the default “godaddy’s 404 error page” to “home page” and viola, everything worked. It did take about 20 minutes for the change to take effect. @GDHosting: c'mon, you guys really need to do a better job of support given how popular wordpress is and that it seems your setup is just quite different from other hosts'. I can say personally that the difficulty with such things has caused me to recommend against GD countless times.

    Thanks again @Ipstenu!!

Topic Closed

This topic has been closed to new replies.

About this Topic