WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks are broken (12 posts)

  1. Ash Scott
    Member
    Posted 1 year ago #

    Hi all,

    I have been developing a website on my localhost, and have just put it over to a virtual server. The only page which loads is the homepage. When I use 'Post Name' as my permalink, it doesn't work, and i get the default apache 404 - Not the custom one on my theme. The same happens when i put %/postname% in the custom structure.

  2. fonglh
    Member
    Posted 1 year ago #

    Does the server have mod_rewrite? Did the .htaccess file get generated correctly?

  3. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

  4. Ash Scott
    Member
    Posted 1 year ago #

    this is what is in my .htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  5. Ash Scott
    Member
    Posted 1 year ago #

    Following what i could of that moving_wordpress article, it still isn't working :(

  6. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Check that anti-hotlinking isn't enabled in your hosting account. If it is, try disabling it.

  7. Ash Scott
    Member
    Posted 1 year ago #

    What do you mean by hosting account?. It has been installed natively on a virtual machine, so I don't have a hosting account :/

    {Moved to Localhost Installs]

  8. Ash Scott
    Member
    Posted 1 year ago #

    i dont know who moved this, as it's not a localhost install. It's a transfer from a localhost server, to a virtual server on the internet - therefore, the issue isn't on localhost.

    I have set mod_rewrite to on, enabled override, deleted and regenerated a .htaccess file. The only way it will work is if I set permalinks to 'index.php/%postname%'.

  9. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Localhost Installs
    – If WordPress is or will be installed on your computer

    http://wordpress.org/support/

  10. Ash Scott
    Member
    Posted 1 year ago #

    exactly.... the website was transferred from localhost to a live internet server, and the issue is with the internet server, therefore, not a localhost issue.

  11. fonglh
    Member
    Posted 1 year ago #

    There's some stuff here on pathinfo permalinks, which seems to be what you have. Might give you some clues on how to get it to work with pretty permalinks.

    http://codex.wordpress.org/Using_Permalinks

  12. The Mighty
    Member
    Posted 1 year ago #

    Try to set the permalink back to Default and see how it goes. If it is work then change the permalink back to any options you like. I had a similar problem and my site worked fine after I tried this.

Topic Closed

This topic has been closed to new replies.

About this Topic