WordPress.org

Ready to get started?Download WordPress

Forums

permalinks appends 'index.php' to urls after server move (5 posts)

  1. ghmercado
    Member
    Posted 7 years ago #

    All my 2.1.3 wordpress sites, which had been around since wp 1.5 and upgraded each time, used to use the structure:

    %year%/%monthnum%/%day%/%postname%/

    ever since a recent server host move, the sites have started to insist on the ff. structure:

    /index.php/%year%/%monthnum%/%day%/%postname%/

    Appending the 'index.php' to all my URLs is a complete disaster as I use the Click Counter by Ozh plugin to count my most clicked links. These all now go to 404 pages. I really wanna keep using this as it has been recording my hits since forever.

    I tried putting it back to without the index.php but it doesn't work out, resulting in errors.

    PLease help!?

  2. ghmercado
    Member
    Posted 7 years ago #

    bump! come on guys a little help?

  3. lelion
    Member
    Posted 7 years ago #

    I can't say why index.php is now appended to the URLs...

    Can you check what's in your .htaccess file, maybe the file changed, and this is the reason for the new URLs?...

    Someone with more knowldge on permalinks might help, I hope...

  4. Chris_K
    Member
    Posted 7 years ago #

    Good place to start: Permalinks

    TONS of trouble-shooting there.

    Is your new server apache or IIS?
    Does it support mod_rewrite?

  5. jamessnell
    Member
    Posted 7 years ago #

    This problem turned out (for me) to be due to my mod_rewrite apache module not being loaded. I also needed to edit my virtual host definition for my site so that AllowOverride was set to "all" and not "none" - which was the default.

    a2enmod rewrite - will enable the rewrite module for apache2
    /etc/init.d/apache2 force-reload -will reload apache2's config

    Have fun,
    J

Topic Closed

This topic has been closed to new replies.

About this Topic