WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalinks and Pages Broken after server move? (6 posts)

  1. Retsujou
    Member
    Posted 6 years ago #

    Hello All.

    I have moved from Server A to Server B

    I have tared up my wordpress directory on A and moved it onto B.
    There is unpacked it and everything is in order.
    I manually moved the .htaccess from Server A to Server B, corrected permissions and installed it.

    I have dumped the mysql database on A and then loaded it on B.

    I can visit the main wordpress page on the new server. I can use the admin interface anmd everything, but whenever I try to load a "Page" I created or whenever I try to use a link directly to the article (permalink?) I get a page not found, a 404. The same applies for any Tag I created.

    Mod_rewrite is loaded, I am a but clueless now?

    what I am seing is:

    [Sun Jul 06 03:30:57 2008] [error] [client 77.96.103.107] File does not exist: /var/www/herowner.com/htdocs/2008, referer: http://herowner.com/
    [Sun Jul 06 03:30:57 2008] [error] [client 77.96.103.107] File does not exist: /var/www/herowner.com/htdocs/favicon.ico, referer: http://herowner.com/2008/06/29/free-pictures-say-hello-to-normion/
    [Sun Jul 06 03:30:58 2008] [error] [client 77.96.103.107] File does not exist: /var/www/herowner.com/htdocs/2008, referer: http://herowner.com/
    [Sun Jul 06 03:30:58 2008] [error] [client 77.96.103.107] File does not exist: /var/www/herowner.com/htdocs/favicon.ico, referer: http://herowner.com/2008/06/29/free-pictures-say-hello-to-normion/
    [Sun Jul 06 03:31:02 2008] [error] [client 77.96.103.107] File does not exist: /var/www/herowner.com/htdocs/wp-content/themes/illacrimo/illacrimo/javascript, referer: http://herowner.com/
    [Sun Jul 06 03:31:07 2008] [error] [client 77.96.103.107] File does not exist: /var/www/herowner.com/htdocs/page, referer: http://herowner.com/

    apache2ctl modules does show mod_rewrite is loaded

    Thank you

  2. Retsujou
    Member
    Posted 6 years ago #

    [Sun Jul 06 03:30:57 2008] [error] [client 77.96.103.107] File does not exist: /var/www/herowner.com/htdocs/2008, referer: http://herowner.com/
    [Sun Jul 06 03:30:57 2008] [error] [client 77.96.103.107] File does not exist: /var/www/herowner.com/htdocs/favicon.ico, referer: http://herowner.com/2008/06/29/free-pictures-say-hello-to-normion/
    [Sun Jul 06 03:30:58 2008] [error] [client 77.96.103.107] File does not exist: /var/www/herowner.com/htdocs/2008, referer: http://herowner.com/
    [Sun Jul 06 03:30:58 2008] [error] [client 77.96.103.107] File does not exist: /var/www/herowner.com/htdocs/favicon.ico, referer: http://herowner.com/2008/06/29/free-pictures-say-hello-to-normion/
    [Sun Jul 06 03:31:02 2008] [error] [client 77.96.103.107] File does not exist: /var/www/herowner.com/htdocs/wp-content/themes/illacrimo/illacrimo/javascript, referer: http://herowner.com/
    [Sun Jul 06 03:31:07 2008] [error] [client 77.96.103.107] File does not exist: /var/www/herowner.com/htdocs/page, referer: http://herowner.com/
  3. macsoft3
    Member
    Posted 6 years ago #

    I suggest you read 'Moving WordPress' found under Docs carefully.

  4. Retsujou
    Member
    Posted 6 years ago #

    Thanks I did that and I find it only describes what I am doing.

    I failed to mention that Server A and Server B will have the exact same domain.

  5. Chris_K
    Member
    Posted 6 years ago #

    A) Is DNS pointing to the correct server?

    B) mod_rewrite is part of the battle. How about AllowOverrides? Is that set properly as well? More troubleshooting stuff at the Permalinks page.

  6. Retsujou
    Member
    Posted 6 years ago #

    Thanks I figured it out.
    On Gentoo with the default setup that I picked, the .htaccess file does not get picked up for virtual hosts which are IP based. Everything is working fine now.

    However the move from Mysql 4 to mysql 5 does not seem to be safe, so I am canceling the whole move.
    It randomly seems to delete parts of posts which messes the whole post up in the end.

    Disappointing, but oh well :)
    Thank you all for the help

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.