WordPress.org

Ready to get started?Download WordPress

Forums

permalinks and .htaccess (14 posts)

  1. larsfarm
    Member
    Posted 9 years ago #

    I just found and installed WordPress 1.5 ( http://www.farm.se/blog/ ). If I enable permalinks (using the examples), wordpress says "cant write .htaccess". There is no .htaccess file at all. So I add an empty .htaccess in the /wp/ directory with write permissions (666) and WordPress fills it with data. But now I get 403 access denied. There is nothing but wordpress data in .htaccess

    Lars

  2. larsfarm
    Member
    Posted 9 years ago #

    Added info that might help: http://www.farm.se/info.php

  3. Try adding /index.php/ to the front of your permalinks.

  4. larsfarm
    Member
    Posted 9 years ago #

    Thanks, this works even if it is a bit ugly.

    Why does this work?

    Lars

  5. Because your host has either messed up mod_rewrite or .htaccess support. Using /index.php/ bypasses both.

  6. andrisig
    Member
    Posted 9 years ago #

    I'm having the exact same problem :/

  7. andrisig
    Member
    Posted 9 years ago #

    Ok, the option Options FollowSymlinks was missing from the WP rewrite rules. Add it to the top if the htaccess file, inside the if statment. This fixed the problem for me .. I'm surprised no one mentioned this right away.

  8. andrisig
    Member
    Posted 9 years ago #

    Why is this Options Symlinks option not set by default by WP?

  9. crazybanjo
    Member
    Posted 9 years ago #

    Okay, please excuse my ignorance, but when you say the following, what, exactly, should I add to my .htaccess file?:

    Ok, the option Options FollowSymlinks was missing from the WP rewrite rules. Add it to the top if the htaccess file, inside the if statment. This fixed the problem for me .. I'm surprised no one mentioned this right away.

    I'm not seeing an if statement, only the following (continues on, but this is the start...)

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [S=40]
    RewriteRule ^(114)/trackback/?$ /index.php?pagename=$1&tb=1 [QSA,L]

  10. marzar00
    Member
    Posted 9 years ago #

    Please help I also am having problems with this. I enabled the permalink and my .htaccess file was 666. When i clicked the enable permalink button or what ever it says a blue box appears and says now go and edit your .htaccess file. ??? i am now getting a 403 error! :(

    The link to my site is: http://www.marzar00.finditmax.com

  11. ceo
    Member
    Posted 9 years ago #

    Just put the line Options FollowSymlinks before the WordPress generated permalink stuff and set htaccess to 666 and it'll work fine.

  12. Sire
    Member
    Posted 9 years ago #

    I've tried all this, the 1st few lines of my .htaccess file looks like this:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    Options +Followsymlinks
    RewriteEngine On

    But as long as the .htaccess file exists my blog won't run.
    Peter

  13. risach
    Member
    Posted 9 years ago #

    I'm also having the same big problem as Peter -- there is some additional information at a different thread:
    http://wordpress.org/support/topic/26121#post-183710
    http://wordpress.org/support/topic/26121#post-184289

    but it says basically the same.
    Still, my situation is just like Peter's: when I delete the .htaccess-file, my blog comes back, but no link except "Login" works; if I try to follow the suggested procedere, replacing .htaccess with an empty plain-text-file, etc., and then try to hit "Update PermaLinks" I just get a 404, 500-error.

    My WP is running on a free remote webserver about which I have very limited knowledge and control -- it apparently runs Apache, but I have no clue what how rewrite_mod is handled.

    Please, if anyone could help?
    That's the rather most serious episode in my WP-experience so far.
    I dont get it that there is no way just to get back to the situation before I started to play with Permalinks (i.e. just hitting the "Update"-button in 'Options'/'Permalinks' ...), to the situation with non-modified links within your blog. I mean, right now, my WP is screwed!

    : /

  14. FranceFan
    Member
    Posted 8 years ago #

    I too am having the same problems. This seems to be a very widespread problem. Has there been any solution to date?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.