WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalinks and Edit posts WP 2.0 beta (50 posts)

  1. estjohn
    Member
    Posted 8 years ago #

    I have downloaded and installed the beta 2.0 version of WP. I have it running at http://wpbeta.aleeya.net/

    When I change the permalink structure to

    Date and name based
    » http://wpbeta.aleeya.net/2005/11/19/sample-post/

    It breaks all of the links. I reverted back to the

    Default
    » http://wpbeta.aleeya.net/?p=123

    and it worked fine again.
    I checked the .htaccess and even chmodded it to 666, but for some reason, it is not updating when I click on the "update permalink structure".

    I do not have any plugins enabled. This is a defualt installation with no tweaks. I renamed the default category to the category for this post. This is the first post on the site.

    Along with that, I noticed that my link opened in the same window. I went back and edited the post for the link to open in a new window. It did not work. The HTML shows before when I click on the HTML link where the post is entered. I also tried to add manually target="_blank" manually, but it did not update either. I have the same problem if I use longdesc="Long description tag" , but Any other edits will save.

    Has anyone else noticed similar things?

  2. vkaryl
    Member
    Posted 8 years ago #

    I always change .htaccess to 777 before I ask wp to write to it, then set it back to 644. I'm using the same thing you tried, date and name based, and it worked (and is working) fine for me.

    Hmm. I've always had the permalinks when clicked on open in the same window, didn't realize people would think that problematic. I hate sites where stuff like that opens in a new window....

  3. estjohn
    Member
    Posted 8 years ago #

    I should have been more specific on the link opening in a new window. That one is not a perma link, but a link in the post itself to an external website. I was trying to get it to open in a new window. I prefer to have pages on my site open in the same window and anything external opening in a new window where possible.

    I tried changing the chmod to 777, it did not work. I checked permissions and it is owned by me as well, so everything is right on permissions. I tried all the different permalinks to choose from, it still did not work. I even tried changing permalinks and then saveing a nd publishing a new post, no go.

    I will try editing the .htaccess by hand and see what that does. No matter what I cahnge the .htaccess to or the permalinks too, it does not change the .htaccess file.

    The timestamp will change on the .htaccess file, but the contents of the file do not change - which I assume it should?

  4. billurell
    Member
    Posted 8 years ago #

    This exact thing is happening to me on WP 1.5.2 I'm new and thought I was crazy and missing something. I have 2 different tutorials one for if mod write is not on server. My host support has verified it active. The other tutorial says just cut and paste. I am trying the same format as you, (ideally) but can get none but default to work. Will try shutting down firewalls next.

  5. Michael Bishop

    Posted 8 years ago #

    I noticed on my install that I was getting 404's, when I clicked on post. I went into the Options->Permalinks, and resaved the permalinks, and all was well.

    Have you tried deleting the .htaccess?

  6. estjohn
    Member
    Posted 8 years ago #

    When I tried to resave permalinks as a differnt one (instead of default) it would give me 404's when I clicked on them, so I had to revert back to default. I ahve not tried deleting the .htaccess, but I will try that thanks!

    -----------
    I deleted the .htaccess and resafved permalinks..
    resaved permalinks.. it still does not work. permissions are 777 and owner is me, same as rest of directory...

    I also tried availble options the default, saved, then back to the one I wanted to chose and saved

  7. Michael Bishop

    Posted 8 years ago #

    I clicked on one of the available options, then back to custom, then saved. Just for reference.

  8. estjohn
    Member
    Posted 8 years ago #

    no matter which option for permalink i choose, it has the same entry in .htaccess

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php
    </IfModule>

    is that correct? Just to veryify, I deleted it again, and set the permissions to read only. so, when I cahnged permalink structure, it will not write and the bottom of the options/permalinks page tells me

    If your .htaccess was writable we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.

    which is fine, thats what I wanted at this time to check this... and in the box, no matter what structure option I choose it still only presents

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php
    </IfModule>

    on all the options. Shouldn't the rewrite options change based on teh structure I choose?

  9. Michael Bishop

    Posted 8 years ago #

    There's some issues, for sure. I just did some testing, and deleted the .htaccess, placed a clean file and played around with different permalinks. It says updating permalinks, but nothing is writing to the .htaccess file, only the default permalinks will work. It's simply not writing the .htaccess. I must have accidently used one of the default when I changed the permalinks earlier.
    I'd call it a bug.

  10. vkaryl
    Member
    Posted 8 years ago #

    estjohn's contents there is exactly what's shown in my .htaccess; this is a permalink from my test install:

    http://netwizardry.net/nightwiz/2005/11/17/night-at-the-wizards-bit/

    So it's working properly on mine.... I have to say I was surprised, simply because I've had a lot of trouble overall with permalinks, with 1.5+ versions.

  11. estjohn
    Member
    Posted 8 years ago #

    vkaryl lol.. I had just the opposite.. none with 1.5..
    vkaryl if you delete the .htaccess and then start with a new one does it still work properly for you via the steps I wrote above?

  12. vkaryl
    Member
    Posted 8 years ago #

    *laughing* I haven't checked, because you see if it ain't broke don't fix it!

    I was going to set up a second testsite anyway, so will do so and see what happens....

  13. estjohn
    Member
    Posted 8 years ago #

    thanks :) I appreciate your alls help with all this! This new test one I am doing is nothing criticial.. so I am not in any hurry or anything.

  14. Michael Bishop

    Posted 8 years ago #

    vkaryl, can you change the permalinks to something like /%year%/%category%/%postname%/ and everything work?

  15. vkaryl
    Member
    Posted 8 years ago #

    Ayup. Here's what I did just now:

    1. Changed the .htaccess file permissions through my ftp client to 777.
    2. Accessed the site admin permalinks section.
    3. Input in Custom what I copied direct from miklb's post above.
    4. Clicked the Update button.
    5. Got the Permalinks updated message.
    6. Accessed the blog, which loaded just fine; copied the permalinks link location, see here: http://netwizardry.net/nightwiz/2005/general/night-at-the-wizards-bit/
    7. Changed .htaccess permissions back to 644 through ftp client.

    Test site in place here: http://netwizardry.net/nightwiz/

  16. estjohn
    Member
    Posted 8 years ago #

    did your .htaccess already have /%year%/%category%/%postname%/ in it to begin with when you did that? That is why I was curious if you deleted the file completely, and then WP creted a new .htaccess when saving, if it would contain the same info. If it is already in there, it might change the timestamp, but no content in it is being changed..

    I took the exact steps you said above and it did not change anything.. hmmm.

  17. Michael Bishop

    Posted 8 years ago #

    Right. I created a new .htaccess file, and tried that permalink, no go.

    http://sandbox.miklb.com/

    If you hover over a post, you'll see it wants to use that permalink, but it takes you to a 404.

    permissions 777 on the .htaccess.

  18. vkaryl
    Member
    Posted 8 years ago #

    If you click on my permalinks, you go to the post....

    estjohn, the line in the permalinks box had /%year%/%monthnum%/%day%/%postname%/ in it in the beginning. Then I copied what miklb suggested above, clicked the radio button next to Custom, and pasted /%year%/%category%/%postname%/ into the box. The .htaccess file ITSELF is exactly the same, from the first time I set it up, to now, with the changed input.

    Which is pretty strange.... SOMETHING should be different. Or it shouldn't be working. But it's working fine.... I don't see how this could be something weird on my host server, though I suppose it's possible. But this isn't even one I'm hosting myself on my reseller space (with a few tweaks of my own in place) - this one's on plain ol' Neutron plan at below10host.com.

    [Edit: my .htaccess file is set at 644 now too....]

  19. Michael Bishop

    Posted 8 years ago #

    Sure, if I copy what's estjohn posted earlier to my .htacess file, then change the permalink, everything's fine. However, if I delete the .htaccess file, WP won't rewrite the new permalinks to it, or anything for that matter, even though it's saying permalink updated.

  20. vkaryl
    Member
    Posted 8 years ago #

    Ah ha.... if I LEAVE the .htaccess file set at 777, I get a 404! and now, setting it back the way it was (644) does not allow it to go to the permalink.... Very strange.

    So I redid the whole process I outlined above, and now it works again. Pretty wonky....

  21. vkaryl
    Member
    Posted 8 years ago #

    I'm not copying directly to my .htaccess file though....

  22. Michael Bishop

    Posted 8 years ago #

    But what we are asking is, what if you delete, or simply rename the .htaccess, and start with no, or a blank .htaccess, do things still work.

  23. vkaryl
    Member
    Posted 8 years ago #

    Well, I did to begin with right after I first installed the beta distro, yes. I can do that again, I guess.

  24. estjohn
    Member
    Posted 8 years ago #

    I am guessing the 644 will not let it write to - even though it says they are updated - and when it is set to 777 it is writing to, but not what it should be.. there fore when it is 777 and it writes to, but not what it should be for that structure... then it is getting the same thing we are getting. with 777, the default is the only one that works correctly.

    just my 2 cent therory.. unfortunately I have been using wordpress for only a month and a half and I do not know much about css and mysql etc to be able to figure out just what is causing all this.

  25. vkaryl
    Member
    Posted 8 years ago #

    Okay. I renamed .htaccess (the original one) and moved it out of the root folder. I created a blank txt file, uploaded it to the root folder, renamed it to .htaccess, chmod it 777, accessed the permalinks page, updated the permalink structure to /%year%/%monthnum%/Úy%/%postname%/, chmod .htaccess back to 644, and yes, permalinks are working just fine for me, though the .htaccess file shows exactly the same stuff estjohn has....

  26. Michael Bishop

    Posted 8 years ago #

    In my case, it won't write anything to the .htaccess, nor will it create one if there's not one in the directory.

    I guess until more documentation regarding that comes along, this will definitely stay in the sandbox.

  27. estjohn
    Member
    Posted 8 years ago #

    vkaryl if you compare the "test" .htaccess to your original one, are they different for permalink structure? If so, this might mean i need to be looking at the actual database entry save instead of the .htaccess file...

    hmm maybe i need to look at permissions of the config file too..

  28. vkaryl
    Member
    Posted 8 years ago #

    Nope. Exactly the same.... and exactly the same as you originally posted:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /nightwiz/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /nightwiz/index.php
    </IfModule>

    Um. I see now that that's not true. While it IS the same as my original (and all the iterations in between), it IS different from your posted contents above - where yours has RewriteRule . /index.php, mine has RewriteRule . /nightwiz/index.php.

    So why I wonder is mine adding a "real" rewrite base folder, and yours isn't?

  29. estjohn
    Member
    Posted 8 years ago #

    well hmm..
    mine is in the "root" of the domain
    http://wpbeta.aleeya.net/

    where yours is in a directory?

    http://netwizardry.net/nightwiz/

    so.. evidentaslly when it is saved, it will save in the mysql database as different things.. since

    /%year%/%monthnum%/%day%/%postname%/
    /archives/%post_id%

    and the default all have the same .htaccess entries?

  30. vkaryl
    Member
    Posted 8 years ago #

    Ah. Since I have so little background in rewrite, I simply didn't realize that it was a difference between root and a subfolder....

    I don't know, estjohn.... I am NO whiz....

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.