WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
Permalinks and 404 Errors (11 posts)

  1. Steve
    Member
    Posted 1 year ago #

    I'm migrating a client from WP e-commerce and need to preserve the existing permalinks as the client has put a lot of effort into getting a high Google ranking. Obviously changing the permalinks would create problems and possibly cause them to lose their rank.

    The URL structure I need is: /store/%PRODUCT_CATEGORY%/%PRODUCT%/

    I've been successful in getting the URL structure I need by changing the 'Shop' page slug to 'store' and modifying the Permalink settings in WooCommerce but am now getting a 404 Error on every product page.

    The URLs/permalinks display/work correctly on the shop page and going to the category pages. However any attempt to access the product via the /store/%PRODUCT_CATEGORY%/%PRODUCT%/ URL results in a 404 error.

    I've verified that the individual products permalink is correct; at least that it displays as needed on the product edit page. But can't figure out the 404 error.

    This is a development site with a fresh install of WP 3.4.2 and the only plugins installed are WooCommerce 1.6.5.2 and Regenerate Thumbnails 2.2.3

    Any suggestions or ideas would be appreciated!

    http://wordpress.org/extend/plugins/woocommerce/

  2. royho
    Member
    Posted 1 year ago #

    Try settings->permalinks click save twice.

  3. Steve
    Member
    Posted 1 year ago #

    Roy, guess I should have mentioned it but that was the first thing I did.

    Been bitten by that one before!

  4. awideman
    Member
    Posted 1 year ago #

    Did you ever figure this out steve? I'm having the same issue.

  5. Steve
    Member
    Posted 1 year ago #

    Afraid not, I've not been able to find a solution at all.

  6. onecloud
    Member
    Posted 1 year ago #

    Hi Steve,

    I'm having the exact same issue even with the latest version of Woocommerce and 3.5.1 of WordPress, see my thread here: http://wordpress.org/support/topic/404-when-clicking-products-in-categories-permalinks I will update you if I get any responses.

  7. supah
    Member
    Posted 1 year ago #

    having the same problem here.

    MOST pages load and work just fine until navigating to individual product pages.

    here: https://supahmarket.com

  8. onecloud
    Member
    Posted 1 year ago #

    Just thought I would let everyone know that I have found a work around that suits my customers requirements. You can see on the dev site here: http://toyspace.onedigital.co.nz or once live here: http://toyspace.co.nz.

    Basically I have set a different Product category base to the main Shop Base page. i.e:

    Permalink Structure
    Product category base browse-toys
    Product permalink base /toy-hire/%product_cat%

    This would make my categories page show on the url toyspace.co.nz/browse-toys/ however for some reason I can actually still get to the individual category pages e.g. toyspace.co.nz/toy-hire/baby-toys/ by using the /toy-hire/ base (I'm guessing because I set the Product Permalink as that base).

    So what I've done is modified the Base Shop Page /toy-hire/ and just copied the HTML code from the /browse-toys/ page into it. Then on the WooCommerce Settings->Pages Tab I've just simply removed the Shop Base Page.

    It does mean that any modifications to the Categories has to be done manually however this shouldn't be a big issue for most customers as the categories would generally be fairly static.

    If you would like any help with your setup you can find our details on our website http://www.onedigital.co.nz

  9. unick69
    Member
    Posted 12 months ago #

    I guess this goes unresolved yet ! I am having the same issues as steve and awideman.

    Basically setting custom category base as

    /static/%product_cat%

    would allow me to navigate to either /static or /static/%product_cat%

    but if I try to go to /static/%product_cat%/product... then I get the 404.

    It would be nice if anyone would have found the source of this conflict as this is the first google search result and still no good fix as been posted 10 month later...

    I'll continue the search and update if I find any useful solution

  10. unick69
    Member
    Posted 12 months ago #

    Ok after a few hours searching and juggling around those settings, I managed to understant the following.

    If I set the Product category base to static and the Product permalink base to /static/%product_cat% I can access either static or /static/%product_cat% fine but it will break (get the 404) on /static/%product_cat%/sample-product

    but if I set the Product permalink base to just %product_cat% then I can access the product page (in this case /%product_cat%/sample-product) just fine.

    but then if I set the "category base part" of Product permalink base to something different (so lets say here static to something like other-static) it will go to the poduct page just fine.

    So it looks like woocommerce doesn't like that the product category base and the product permalink base having the same "category base part" as part of the permalink.

    Now is this normal behaviour ? is it a Woocommerce related issue or a is it a limitation of WordPress...

    I would greatly appreciate anyone who could shed some light on this matter and give some tips on how to fix this or what alternative would be possible as I find it pretty messy (from a user standpoint) having a different hierarchy for the category and for the product!

    Thanks

  11. dorothai
    Member
    Posted 11 months ago #

    In my case it simply looses the parent
    /kids-store/girls-clothes/dresses/pink-cotton-summer-dress
    all works fine to
    /kids-store/girls-clothes/dresses/
    then 404 error
    latest version of woocommerce and wp 3.6.1
    it only works as such:
    /kids-store/dresses/pink-cotton-summer-dress
    So I conclude that not all parents are fetched properly it looks like only the direct parent is found.
    Keep on looking - it's not a wp issue - I am pretty sure about this because all worked fine until I played with shop page in combo with their woo permalinks in wp permalinks settings - since then bad luck.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic