WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks (7 posts)

  1. Ballet News Admin
    Member
    Posted 2 years ago #

    I changed the permalink structure from the default one to /%postname%/ and since then, my LinkWithin pplugin has been returing 404 errors.

    How do I get it to pick up the new links rather than the old ones ?

    I have tried contacting the plugin company three times but they have not replied. I'm really in need of getting this plugin working properly and have tried re-grabbing the code etc to no avail.

  2. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Starting Permalinks with %postname% is strongly not recommended for performance reasons.

    http://codex.wordpress.org/Using_Permalinks

  3. WordWeaver777
    Member
    Posted 2 years ago #

    Ballet, I have a similar -- although not exactly the same -- problem, after switching to pretty links a few days ago. Please read my recent post and see if you can relate to it. In a word, Googlebot is getting dozens of 404 errors when it makes a request for a URL on my blog using a full pretty link.

    Also, I get zero results when doing a WP search on my blog using the full post title. Yet, if I search using just a few keywords that are in the title, the article in question shows up on the WP results page.

    I am wondering if older posts are stored in the mySQL database using the default page scheme -- ?p=123 -- and that is why Google gets a 404 error when using the pretty link version of the same post.

    I am not sure here. I am just theorizing.

  4. WordWeaver777
    Member
    Posted 2 years ago #

    Ballet, I just wanted to let you know how I fixed my problem, in case it helps you resolve yours as well.

    In a word, yesterday when I installed WP Super Cache, I messed up the rewrite rules that are in the htaccess file for my blog's root directory. This seems to have broken the redirects.

    Now that I have fixed the htaccess file, the Googlebot is no longer getting 404's when it makes requests using pretty links, and I now get the right search results when I use a full post title in WP's search engine.

  5. Ballet News Admin
    Member
    Posted 2 years ago #

    thanks WordWeaver777. I'll see if my web developer did anything like that as he very recently installed that caching plugin.

    It is ironic that as wordpress prides itself on having all these plugins that can easily be added to do all kinds of amazing things, most of my time is spent working out why one is clashing with either my theme or another plugin. Why can't wp have a system like Apple does for vigorously checking all of the plugins before they are released ? Would save an awful lot of time for customers so aren't tech savvy and have no clue how to fix these annoying clashes. It's all very well being free but if it doesn't work......!! Charge the plugin people to make them and lets have a better quality.

    On performance - I was aware of this but as my website isn't an issue in that regard I made the change. I'm not going to make another change to the permalinks - that's just pointless, so I need to find a solution to this annoying problem.

  6. Ballet News Admin
    Member
    Posted 2 years ago #

    I shoudl clarify - it's not just about better quality pluings, it's about plugins that work across a range of themes and with other plugins. I don't think the system works with developers making plugins in osloation. Look at the number of updates that come through all the time.... they should be properly developed first and then updated only when wp is. Just my view, but if the plugins are the jewel in the crown they they really haven't impressed me and I avoid them wherever I can.

  7. WordWeaver777
    Member
    Posted 2 years ago #

    Installing WP Super Cache can be a bit confusing if you are not familiar with it, or with .htaccess files. It took me a day to figure out what I was doing wrong, which was resulting in a lot of 404 errors with the Googlebot.

    Basically, BEFORE you hit the "Update Mod_Rewrite Rules" button on the "Advanced" tab of the "WP Super Cache Settings" page in WP, you need to do this:

    1. Make sure there is an .htaccess file at the top level of your blog, that is, in your blog's root directory.

    2. Make sure there is also an .htaccess file in "wp-content/cache/"

    3. If a .htaccess file does not exist in either one of these two places -- they are normally invisible -- you can make them yourself in the Terminal.

    4. Using the Terminal, cd to the directory where the .htaccess file needs to be created.

    5. Type "sudo pico .htaccess" to create the file.

    6. Enter your admin password when requested.

    7. Save the newly-created .htaccess file.

    8. Once you are sure that these two .htaccess files exist, you need to open the one that is located in "wp-content/cache" and add the following rule to it:

    # BEGIN WordPress
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    9. Save the edited .htaccess file.

    10. At this point, I advise you to reboot your server just to play it safe.

    11. Once you have rebooted your server, go back to the "Advanced" tab of the "WP Super Cache Settings" page and hit the "Update Mod_Rewrite Rules" button. WP Super Cache will then inform you that it has added the necessary rewrite rules to both of the aforementioned .htaccess files.

    12. You should now be good to go. You can go to the "Contents" tab and click on the link there in order to see exactly what WP Super Cache is doing for you insofar as caching is concerned.

    I hope this little tutorial helps some of you.

Topic Closed

This topic has been closed to new replies.

About this Topic