WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks (10 posts)

  1. louie37
    Member
    Posted 6 years ago #

    I have upgraded to the latest version last night and since then i get the following error on permalinks:

    Warning: preg_match() [function.preg-match]: Compilation failed: unrecognized character after (? at offset 3 in .../blog/wp-includes/classes.php on line 99
    
    Warning: preg_match() [function.preg-match]: Compilation failed: unrecognized character after (? at offset 3 in .../blog/wp-includes/classes.php on line 100
    
    Warning: preg_match() [function.preg-match]: Compilation failed: unrecognized character after (? at offset 3 in .../blog/wp-includes/classes.php on line 99
    
    Warning: preg_match() [function.preg-match]: Compilation failed: unrecognized character after (? at offset 3 in .../blog/wp-includes/classes.php on line 100
    
    ....................
    
    Warning: preg_match() [function.preg-match]: Compilation failed: nothing to repeat at offset 1 in .../blog/wp-includes/classes.php on line 100

    I have followed all the instruction (back-up, delete old files, disabled plugins, etc) but the only way to get it working is to revert to default all the time.

  2. louie37
    Member
    Posted 6 years ago #

    for the moment got it sorted out by adding the top 2 lines in the .htaccess file, but i really want to get this sorted out without the error reporting off:

    php_flag display_errors off
    php_flag display_startup_errors off
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>
    #END WordPress
  3. bringthebeats
    Member
    Posted 6 years ago #

    I'm having similar troubles. My permalinks aren't working with this new update. I have links all over my site and on messageboards so the default links aren't an option for me. Can someone please help asap?

  4. louie37
    Member
    Posted 6 years ago #

    reset to default, then back to the option you had.

    edit your .htaccess file and add the code above (php_flag..) to it at the very top.

    That worked out for me for the moment.

  5. bringthebeats
    Member
    Posted 6 years ago #

    unfortunately no go. but thanks. any other suggestions... who knows when my provider will figure it out?

  6. louie37
    Member
    Posted 6 years ago #

    can you revert it back to the previuos one?

    And what version was before upgrade?

  7. bringthebeats
    Member
    Posted 6 years ago #

    i went from the last version of 2.2... whatever that one was... directly to 2.31. could that be a problem?

  8. louie37
    Member
    Posted 6 years ago #

    yes it could be. after uploading the new files did you go to the wp_admin/upgrade.php page?

  9. bringthebeats
    Member
    Posted 6 years ago #

    yes most definitely. and everything seemed to update fine.

  10. bringthebeats
    Member
    Posted 6 years ago #

    found the answer...

    http://www.joelika.com/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.