WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalinks, 404s etc (12 posts)

  1. CallMeAndy
    Member
    Posted 1 year ago #

    I am sure its been asked before so please forgive me if I am going over old ground but I have spent ages looking and can only find old posts and or posts with exhausted ideas.

    Permalinks do not seem to be working correctly what am I doing wrong.

    When the default setting is used everything works, but this from what I read is not acceptable for use with buddypress. Which I require.

    When numeric is used all I get are 404 errors on every page

    This is a localhost install which I decided was required to avoid problems such as these on a production site.

    So what have I done:
    Deactivated all plugins. No change.
    Verified that mod_rewrite is enabled in httpd.conf. Yes

    Added this to httpd.conf:
    <Directory "C:/Documents and Settings/Andrew Seabrook/My Documents/MyWeb/adventurebod/20120706/adventurebod">
    Options Indexes FollowSymLinks
    AllowOverride FileInfo # Also tried All
    Order allow,deny
    Allow from all
    </Directory>

    Verified that .htaccess is in the wordpress root and that its settings are thus:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /adventurebod/20120706/adventurebod/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /adventurebod/20120706/adventurebod/index.php [L]
    </IfModule>

    # END WordPress

    read that a possible solution is to add;
    Options +FollowSymLinks as the uppermost statement in htaccess
    This pulls up 500 Internal server Error on all pages.

    I noticed there are some apparent errors with wordpress however.
    One thing of note when resetting the permalinks on the admin interface the .htaccess file is amended or created? Either way it is creating it in c:\ which is niether my project root or my apache DocumentRoot (the latter being MyWeb in the httpd.conf directory statement above)

    Additionally it is writing the line: "RewriteBase /adventurebod/20120706_/adventurebod/" which of course is not correct. The underscorer should not be present. It should read "RewriteBase /adventurebod/20120706/adventurebod/"

    So anyone any further thought ideas with this please?

  2. s_ha_dum
    Member
    Posted 1 year ago #

    One thing of note when resetting the permalinks on the admin interface the .htaccess file is amended or created?

    It is supposed to do that.

    Either way it is creating it in c:\ which is niether my project root or my apache DocumentRoot (the latter being MyWeb in the httpd.conf directory statement above)

    WordPress shouldn't be able to do anything at all outside of Apache's DocumentRoot unless something is badly wrong with your server. Are you sure that your DocumentRoot is where you think it is? That is, can you access a simple .html file in that directory?

    What did you use to edit your httpd.conf file? Perhaps you introduced some hidden control characters?

    I have no experience with Apache on Windows but I do know that Windows uses backslashes (\) for directory delimiters, not forward slashes (/). Are you sure that that "<Directory "C:/Documents..." line is correct? Sincere question. Apache could be compensating/converting those slashes. I am not sure.

  3. CallMeAndy
    Member
    Posted 1 year ago #

    Thanks for getting back to me.

    It is supposed to do that.

    Yes just wasnt sure if wordPress amended as well as created the htaccess file.

    WordPress shouldn't be able to do anything at all outside of Apache's DocumentRoot unless something is badly wrong with your server.

    This is the whole point of my inclduding this note within the post - something is either wrong with wordpress or my environment is not appropriate for WordPress, however the question is what.

    Of course there is a difference between something badly wrong with the server configuration in terms of WordPress's requisite and that of a valid configuration of Apache for other purposes. I am running about 3 other regular apache/mysql/php applications on it without issue.

    And have developed many AMP websites without issue. So the question remains what does WordPress require?

    Windows convention is to use backslashes (\) for directory delimiters but in fact (try it in windows explorer) it can interpret forward slashes perfectly well. I believe it is a common practice when developing on a WAMP environment, an application that will be deployed in a LAMP production environment, to use the forward slash syntax as deployment issues are then mitigated.

    Either way in case of some sort of wordpress quirk I tried it with both delimiters. Neither have any difference in effect.

    DocumentRoot is most definitely where I stated it to be and there are no embedded hidden characters in httpd.conf. FYI using Notepad++.

  4. s_ha_dum
    Member
    Posted 1 year ago #

    And have developed many AMP websites without issue. So the question remains what does WordPress require?

    It isn't all that demanding really-- WordPress Requirements.

    Windows convention is to use backslashes (\) for directory delimiters but in fact (try it in windows explorer) it can interpret forward slashes perfectly well.

    Explorer can. The shell can't though and I wasn't sure which mattered for WAMP. But since you tested things, that isn't it.

    What do you mean by 'numeric' permalinks?

    What do you have at wp-admin->Settings->General for the two address/url fields a couple of text inputs down?

  5. CallMeAndy
    Member
    Posted 1 year ago #

    It isn't all that demanding really-- WordPress Requirements.

    Yes well I meet all the basic requirements, and until trying to sort out permalinks everything was ok. The problem is what is required for wordpress permalinks!

    Explorer can. The shell can't though and I wasn't sure which mattered for WAMP.

    I am not sure that the shell is relevent. As I understand things Apache interacts with the kernel. Which as mentioned has no problem undertsanding "/". I use it this way all the time, first one at random from another project
    include "includes/mastandnav.inc.htm";

    WAMP works fine with forwardslashes I think this is a red herring.

    Settings - Permalinks - Common Settings - Numeric
    As in the adminsitrative interface at wp-admin.

    They are both localised - i.e http://localhost/adventurebod/20120706/adventurebod

  6. s_ha_dum
    Member
    Posted 1 year ago #

    WAMP works fine with forwardslashes I think this is a red herring.

    To quote me, "But since you tested things, that isn't it."

    I've not seen this behavior before. Sorry.

    Requirements for permalinks should be mod_rewrite and AllowOverride Fileinfo.

  7. CallMeAndy
    Member
    Posted 1 year ago #

    You did indeed follow what I said and you reiterated it above. I merely wished to underline things for anyone else following this thread.

    Thanks for your help.

    So if anyone else can make any suggestions on this it would be appreciated.

    To recap
    on setting permalinks to the Numeric method in admin settings I am getting 404 Page not found messages on all links. In fact it applies to any setting other than the default method.

    Platform is WAMP on localhost.
    The auto creation of htaccess is not being done as per expectations i.e. it is being written to the system root directory i.e "c:\"
    This is neither Apache documentRoot or the WordPress root.
    Also the lines it is writing in the file are incoreect (seemingly like a bug)

  8. CallMeAndy
    Member
    Posted 1 year ago #

    OK Solved the Permalinks problem.

    Its with Apache - httpd.conf

    As I mentioned above no problems with other php installations and I failed to see the obvious - its a problem in the Directory Directive.

    Options Indexes FollowSymLinks fails
    Options FollowSymLinks Works

    As regards the erroneous writing of htaccess this seems to be something to do with using a child theme. I dont know anything really about the way child themes are implemented however the only thing that I was morphing was css using simple html tags all functionality was directly inherited. Removing the child theme resolved this issue.

    Anyway time to move on for me I think.

  9. s_ha_dum
    Member
    Posted 1 year ago #

    Glad you solved it.

  10. CallMeAndy
    Member
    Posted 1 year ago #

    Resolved

  11. mariobarba
    Member
    Posted 1 year ago #

    Hi
    If I select any permalinks other than the default it corrupts my htaccess file & then I cant login to the site after that.

    My server host said this:
    The default .htaccess rule set for WordPress is:

    ---
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    ---

    The issue was that, the rewrite rules to redirect translationdoctor.co.uk to http://www.translationdoctor.co.uk in your main .htaccess file as shown below:

    ---
    #RewriteCond %{HTTP_HOST} .
    #RewriteCond %{HTTP_HOST} !^www\.translationdoctor\.co\.uk [NC]
    #RewriteRule (.*) http://www.translationdoctor\.co\.uk/$1 [R=301,L]
    ---

    and the option to disable/enable various permalink options in WordPress admin panel is conflicting, because of which WordPress ends up erasing the default rules for its own .htaccess file (wp/.htaccess), making the blog inaccessible. As of now, I have disabled the www redirect by commenting out the above rules, and everything is working fine now.

    To be able to use both the options, you will need to seek assistance from WordPress.
    -------------------

    Can you help?

  12. keesiemeijer
    moderator
    Posted 1 year ago #

    @mariobarba
    Please create your own topic. As this is a resolved topic less people will look at it.
    http://wordpress.org/support/forum/how-to-and-troubleshooting#postform

Topic Closed

This topic has been closed to new replies.

About this Topic