WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalinks 404 error (4 posts)

  1. emu8888
    Member
    Posted 3 years ago #

    Hello,

    I am just trying to switch between the permalink options given by wordpress (ultimately I just want to swap page ID with page name).

    I have the following code in .htaccess in htdocs file but still getting 404 error - what else do I need? Thanks

    # BEGIN WordPress

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  2. SGHB
    Member
    Posted 3 years ago #

    In your Dashboard, go to

    Settings >> Permalinks

    And in Custom Structure put

    /%postname%/

  3. emu8888
    Member
    Posted 3 years ago #

    Hi there, yep I can do that (and it creates the url I want) but when I look up a page I get a 404 error:

    Not Found
    The requested URL /workshops/ was not found on this server.
    Apache/2.2.3 (CentOS) Server at http://www.duet-studio.com Port 80

    i.e. its not a problem with whats in Settings/Permalinks its something to do with rewriting urls? (I've already edited the .htaccess file)

    Any help appreciated.

  4. emu8888
    Member
    Posted 3 years ago #

    Aha got my host to sort it out, something not enabled on their side.

Topic Closed

This topic has been closed to new replies.

About this Topic