WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks (10 posts)

  1. Joe
    Member
    Posted 1 year ago #

    Hello,

    I am fairly new to wordpress (go-figure)and I built a site using the default permalink structure then changed it to /%postname% and my front-page shows but when I navigate through the site i just get a 'page not found' error. Any ideas on how to fix this?

    I haven't made any changes to the htaccess manually, and this is still hosted on my local machine FYI.

  2. ClaytonJames
    Member
    Posted 1 year ago #

    Your .htaccess file isn't being updated. When you click the save changes button at the bottom of the permalinks page, do you get a message such as;

    "If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file" ?

  3. Joe
    Member
    Posted 1 year ago #

    Hello ClaytonJames,

    Thank you for your response, when I update this through wordpress I don't receive a message saying anything similar to that, only saying "Permalink Structure Updated"

    I looked at my .htaccess file before and after and see that it is being changed too...still at a loss at how to fix this.

  4. ClaytonJames
    Member
    Posted 1 year ago #

    Can you tell us a little about your localhost setup? Is it installed on Windows or linux, and what did you choose for a server package? e.g. WampServer, XAMPP, etc...

  5. cyngate
    Member
    Posted 1 year ago #

    try phpinfo and see if mod_rewrite is enabled

  6. Joe
    Member
    Posted 1 year ago #

    Hello ClaytonJames,

    I am installed on a windows with WAMP. Other than that, I am pretty sure all is set to default because I haven't changed anything else.

    Hello Cyngate,

    Where would I check this? I looked in phpmyadmin and couldn't find anything. Sorry, I'm new to this.

  7. ken1990julius
    Member
    Posted 1 year ago #

    you have to enable rewrite in php.ini. you need to run command on your windows machine that will enable mod_rewrite similar or equivalent to a2enmod rewrite on Ubuntu machine with xampp. and when you make changes in to your .htaccess file you need to put it in your site or WordPress main folder. also you will in most cases get this message -"If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file" ?

  8. ClaytonJames
    Member
    Posted 1 year ago #

    I am installed on a windows with WAMP.

    If that's the WampServer package, I think all you might need to do is click on the green icon in the system tray/tool bar area, select Apache > Apache modules > then scroll down the module list until you come to "rewrite_module", and place a check mark next to it.That should enable mod_rewrite. You may have to restart apache, but I think WampServer automatically restarts for you in most cases.

  9. Joe
    Member
    Posted 1 year ago #

    Hello ClaytonJames,

    Thank you very much! That fixed my problem. You're a hero of mine now.

  10. ClaytonJames
    Member
    Posted 1 year ago #

    You're welcome! Glad it turned out well.

Topic Closed

This topic has been closed to new replies.

About this Topic