WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalinks (8 posts)

  1. dealfiles
    Member
    Posted 7 years ago #

    I am trying to change my permalinks from the default
    (ie. ?p=8) to custom (name of post)

    The problem is, I keep getting a "404- file not found" when I try to navigate to my posts.

    Not sure what I'm doing wrong, but any help is appreciated.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    Do you have the .htaccess file? What's in it?

  3. dealfiles
    Member
    Posted 7 years ago #

    I do have the .htaccess file in the root directory of my WordPress Blog. Permissions are set to 666; the file is empty. Thanks.

  4. Chris_K
    Member
    Posted 7 years ago #

    Lots of troubleshooting ideas at the Permalinks page.

    Note: When you're at Options -> Permalinks, scroll down a bit. If WordPress can't write to your .htaccess file, it will tell you what you need to put in it.

  5. dealfiles
    Member
    Posted 7 years ago #

    Yes... already checked that. WordPress is not mentioning the .htaccess file when I update permalinks. It just says that the permalinks have been updated.

  6. Chris_K
    Member
    Posted 7 years ago #

    and the .htaccess in the main wordpress directory remains blank? Weird.

    Try setting the .htaccess to be read-only. Now when visiting Options -> Permalinks does it tell you what to put in there?

  7. dealfiles
    Member
    Posted 7 years ago #

    That did it...

    Set the .htaccess permissions to 444, then updated permalink structure. It provided new code for the .htaccess file, which I wrote to the file, then i changed the permissions back to 666.

    Now the permalink change works! Thanks!

    Should I leave the permissions of .htaccess set at 666?

  8. Chris_K
    Member
    Posted 7 years ago #

    I'd probably just leave it at 444 so nothing inadvertantly clobbers it. :-)

Topic Closed

This topic has been closed to new replies.

About this Topic