WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalink/.htaccess problem -- just not working (5 posts)

  1. kenwinstoncaine
    Member
    Posted 8 years ago #

    I am so not getting this. (Two days and many hours now. And have tried everything (except for editing Apache--which is beyond me) I found at http://wordpress.org/support/topic/26121.)

    I'm using WordPress 1.5.2.

    My file structure is http://www.wellnessU.org/Mind-Body-Spirit-Bulletin

    Mind-Body-Spirit-Bulletin is the WordPress installation file.

    I am trying to create the following simple permalinks:

    /http:/www.wellnessu.org/Mind-Body-Spirit-Bulletin/%category%/%post_id%/%postname%/

    I enter that into the Structure box on the Edit Permalink Structure page at http://www.wellnessu.org/Mind-Body-Spirit-Bulletin/wp-admin/options-permalink.php.

    I click Update Permalinks. (Incidentally, I much earlier created an .htaccess file with permissions set to 666 at http://www.wellnessU.org/Mind-Body-Spirit-Bulletin/.htaccess).

    WordPress 1.5.2 does not automatically create an .htaccess file for me nor update my htaccess file but tells me to do so. So I copy and paste the code from the box into the .htaccess file and save.

    Go to http://www.wellnessu.org/Mind-Body-Spirit-Bulletin/ and click on the title of the first (sample) post on the page and I am taken to the Edit Permalink Structure page at http://www.wellnessu.org/Mind-Body-Spirit-Bulletin/wp-admin/options-permalink.php.

    Time for me to stop doing the same old things over and over that are getting the same old bad results and ask for help.

    My host tells me I DO have mod_rewrite.

    I DO have an .htaccess file in my domain's root directory which is controlling another program. Could that be a conflict? And, if so, how to resolve?

    Suggestions?

    Thank you,
    kwc

  2. kenwinstoncaine
    Member
    Posted 8 years ago #

    I MAY have found part of the problem!

    Under General Options, somehow I had the blog address as:
    http://www.wellnessu.org/Mind-Body-Spirit-Bulletin/wp-admin/options-permalink.php

    BUT.... When I delete that and try to Update Options, I get the message:

    --
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, webmaster@wellnessu.org and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.
    --

    Any idea what to do next? What have I broken now?

  3. kenwinstoncaine
    Member
    Posted 8 years ago #

    Update: Deleting a second .htaccess file that I had created and put in the theme folder seems to have resolved the "internal server error." But I still don't have my permalinks working.

    Am now suspecting it has something to do with my default category. Which is something I've tried to change in Options/Writing. I have changed it from EcoLiving to Journal there. But in Category management, when I try to delete EcoLiving, I'm told that I can't delete it because it is the default category. So there's a puzzle.

    Why I suspect this is playing some role is because for some reason my original test post, which I believed I was posting in a different category, ended up posting as a subcategory of EcoLiving.

    Could it be that since my Structure does not show subcategories that that is why the permalink is not working?

    Thanks,
    kwc

  4. Try removing the /%category%/ tag from your structure. At this time, that tag only works properly on Apache 2 servers.

  5. kenwinstoncaine
    Member
    Posted 8 years ago #

    That was it!

    I took an awful lot of twists and turns with this one. And because I'd changed so many things, was going to close out this post and start a new one to make things less confusing. And then you came along and solved it, macmanx.

    Thanks again for all you do.

    kwc

Topic Closed

This topic has been closed to new replies.

About this Topic