WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalink WordPress 3.4.1 Why must set to default (14 posts)

  1. orie1212
    Member
    Posted 2 years ago #

    Last few hours ago I updated my web to the lastest wp. But I got a problem.
    The Permalink is not fully working with other custom setting EXCEPT the default.
    So, if I click my detail post / page the page still same like in Home Page (domain.com). Then I set the permalink to default ?p=123, that's working.

    I need help, how to configure like I set before with custom link Month and Name?
    I have no backup files or anything before update the wp, so I can't do restore.

  2. orie1212
    Member
    Posted 2 years ago #

    After I installed wp 3.4.1 on localhost, all of custom permalink is fully working. I think this is because of plugin.. Hmm....

  3. wpsecuritylock
    Member
    Posted 2 years ago #

    Try deactivating all your plugins and test your permalinks. If that works, then you can re-activate one at a time and see which plugin is causing issues. Next would be to diagnose if it's a theme issue, try the default WordPress theme and see if your permalinks work then.

  4. sentient127
    Member
    Posted 2 years ago #

    This same issue is happening to one of my site, http://21gents.com. The privacy policy page doesn't render unless we revert the Permalink settings back to default, which isn't an option. In addition, we deactivated all our plugins, and the issue persisted. Does anyone have a possible solution to this issue?

  5. orie1212
    Member
    Posted 2 years ago #

    I don't know exactly what is the caused. But, after I deactived all of my plugin then active all plugin again, it's solved. All of custom permalink can be use again.

  6. NHL23
    Member
    Posted 2 years ago #

    Pulling out my hair with this. Whose your host Sent?

  7. sentient127
    Member
    Posted 2 years ago #

    Hi NHL23. Thanks for the PM. I host my site with http://www.hostway.com. I recently tried to reinstall the latest version of WP and still did not work.

  8. brithulsizer
    Member
    Posted 1 year ago #

    sentient127: Did you ever find a solution? I'm having the same issue.

  9. sentient127
    Member
    Posted 1 year ago #

    Hi brit. Still no solution. I've tried:

    • Deactivating all plugins
    • Reinstalling the most recent version of WP
    • Activating a default theme (clicking the privacy policy link only refreshes the page)
  10. masterwoo
    Member
    Posted 1 year ago #

    change permalinks to old and then to new and then save setting. Hope that will solve the issue.

  11. hoodhendrix
    Member
    Posted 1 year ago #

    why does this say resolved up top and i have not read any solution whatsoever.

  12. sentient127
    Member
    Posted 1 year ago #

    Finally figured out the issue. My host updated my PHP to the latest version available on the server. After encountering another issue due to this upgrade (HTTP error when uploading images and not generating thumbnails), I asked my host to downgrade back to PHP Version 5.2.6. This fixed the page issue AND the image upload issue mentioned above.

    Hope this helps! Best of luck, everyone.

  13. sentient127
    Member
    Posted 1 year ago #

    Spoke too soon. Downgrading the version only resolved the image issue. The pages are still showing up with "There are no posts in this category". Apologies for sharing the wrong info.

  14. sentient127
    Member
    Posted 1 year ago #

    I found the solution for my problem and it's a simple fix.

    Simply add the following to your functions.php and refresh your page. It should render. After it does, delete the line off the functions.php.

    global $wp_rewrite; $wp_rewrite->flush_rules();

    The solution can be found here: http://wordpress.stackexchange.com/questions/5858/category-links-suddenly-started-giving-404-errors

    Good luck everyone!

Topic Closed

This topic has been closed to new replies.

About this Topic