WordPress.org

Ready to get started?Download WordPress

Forums

Permalink weirds out archive links (4 posts)

  1. zoblue
    Member
    Posted 9 years ago #

    Ok, I've now turned on Permalinks on my WP. All the links are fine except for the archive links (see column on the right):
    http://zoblue.com/wordpress/index.php
    If you roll over the Archive linkst, the status bar shows nothing. When you click on any one of the months, the link shows up like so:
    http://zoblue.com/wordpress/%day%-08
    The permalink setting I used is this:
    /%day%-%monthnum%-%year%/%postname%
    The rewrite rules WP gave me are:
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^category/(.*)/(feed|rdf|rss|rss2|atom)/?$ /wordpress/wp-feed.php?category_name=$1&feed=$2 [QSA]
    RewriteRule ^category/?(.*) /wordpress/index.php?category_name=$1 [QSA]
    RewriteRule ^author/(.*)/(feed|rdf|rss|rss2|atom)/?$ /wordpress/wp-feed.php?author_name=$1&feed=$2 [QSA]
    RewriteRule ^author/?(.*) /wordpress/index.php?author_name=$1 [QSA]
    RewriteRule ^([0-9]{1,2})-([0-9]{1,2})?-([0-9]{4})?/?([_0-9a-z-]+)?([0-9]+)?/?$ /wordpress/index.php?day=$1&monthnum=$2&year=$3&name=$4&page=$5 [QSA]
    RewriteRule ^([0-9]{1,2})-([0-9]{1,2})?-([0-9]{4})/([_0-9a-z-]+)?/(feed|rdf|rss|rss2|atom)/?$ /wordpress/wp-feed.php?day=$1&monthnum=$2&year=$3&name=$4&feed=$5 [QSA]
    RewriteRule ^([0-9]{1,2})-([0-9]{1,2})?-([0-9]{4})/([_0-9a-z-]+)?/trackback/?$ /wordpress/wp-trackback.php?day=$1&monthnum=$2&year=$3&name=$4 [QSA]
    RewriteRule ^feed/?([_0-9a-z-]+)?/?$ /wordpress/wp-feed.php?feed=$1 [QSA]
    RewriteRule ^comments/feed/?([_0-9a-z-]+)?/?$ /wordpress/wp-feed.php?feed=$1&withcomments=1 [QSA]

    any help is much appreciated! Do I have to change a parameter in the archive link function?
    thanks in advance,
    Zulema

  2. zoblue
    Member
    Posted 9 years ago #

    I hope this isn't a tough question to answer? Should I turn permalinks off? What did I do?

  3. Ryan Boren
    WordPress Dev
    Posted 9 years ago #

    This is a known bug in 1.2. Get rid of the dashes, use slashes instead.

  4. zoblue
    Member
    Posted 9 years ago #

    Ah, ok. That worked splendidly, thanks! One thing to note for future users is that the permalink structure worked better with the year, then the month, then the day:
    /%year%/%monthnum%/%day%/%postname%
    any other combo wouldn't work for me.
    thanks again!
    Zulema

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.