WordPress.org

Ready to get started?Download WordPress

Forums

External Videos
Permalink URLs (7 posts)

  1. DanielViverridae
    Member
    Posted 3 years ago #

    Hello and first of all a big kudos for a very nice and useful plugin!

    While it has a few shortcomings (i.e there's no possibility to set a default video size), there is one matter that stands out: the video links don't follow the WordPress settings for permalinks. I'm using the "year/month/date/postname" format for all my posts, but External Videos still uses addresses like "?post_type=external-videos&p=148".

    I tried using the "year/month/date/postname" format with a video post created by External Videos, and it worked just fine (!), but the address got changed to the wrong format again after the page had loaded.

    Is there anything to do about it?

  2. silviapfeiffer1
    Member
    Plugin Author

    Posted 3 years ago #

    Hmm, I believe this is a matter for the post type extension framework that WordPress provides. I certainly am doing nothing in my code to change / redirect URLs.

  3. DanielViverridae
    Member
    Posted 3 years ago #

    Okies, I believe I got it sorted out with help from another thread: http://wordpress.org/support/topic/custom-post-types-permalinks-404?replies=15

    Apparently there's a "rewrite" argument that needs to be set to at least "true" when registering a new post type. Now on with resizing videos, hehe.

  4. silviapfeiffer1
    Member
    Plugin Author

    Posted 3 years ago #

    Let me know when you got it working and send me a patch. I'd be more than happy to apply it.

  5. NetBizCoach
    Member
    Posted 3 years ago #

    Is there an update coming with this patch/feature?

  6. dandy_o
    Member
    Posted 2 years ago #

    Apparently not :-)
    I've got the same problem, I can't apply the plugin to a specific page without renaming it "External Videos", and the post doesn't appear in my archives. Trying to get a solution by myself but if you have one, i'll be "more than happy to apply it" too ;-)

  7. silviapfeiffer1
    Member
    Plugin Author

    Posted 2 years ago #

    I've removed the "rewrite" parameter from the register_post_type function, so hopefully it should just work now (after the next release).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic