WordPress.org

Ready to get started?Download WordPress

Forums

permalink updated error on page. not found. (20 posts)

  1. HustleTurtle
    Member
    Posted 8 years ago #

    i update the permalink on the wordpress admin to
    /%year%/%monthnum%/%day%/%postname%/%post_id%/
    i check the site and now the post pages dont apprear

    Not Found
    The requested URL /2005/09/26/test-date/6/ was not found on this server.

  2. HustleTurtle
    Member
    Posted 8 years ago #

    how do i deal with the htaccess file ?

  3. matteoraggi
    Blocked
    Posted 8 years ago #

    I have the same error on http://www.grydladzieci.net and I don't know why, I have a lot of wordpress sites that are going correctly: http://www.matteoraggi.com

  4. petit
    Member
    Posted 8 years ago #

    Have you tried this: ( Valid for WP 2.0 )
    1. Delete your .htaccess ( You may make a backup first :)
    2. Create an empty .htacess file
    3. Set permissions on .htacess to 777 ( most relaxed )
    4. In Admin Options/Permalinks select the Pernalinks structure you want
    5. Click "Update..."
    WP 2.0 should write the correct content in your .htacess file

  5. ccf
    Member
    Posted 8 years ago #

    I am interested but do not find an .htaccess anywhere. If I create one, which folder should it be in?

  6. petit
    Member
    Posted 8 years ago #

    It should be in the root of your blog, i.e. installation folder or topmost folder of your blog ( together with wp-config.php and others ).

    The .htacess file is not part of the distribution of WordPress. Not every host ( web hotel ) allows the redirects in .htacess needed for "pretty permalinks".

    Try the recepi above

  7. jjacobsen
    Member
    Posted 8 years ago #

    I had a similar problem and discovered that the rewrite_rules from the original permalink structure get stored in the database and don't get updated when you change to the new permalink structure. If you find that record in the database and blank it out it will then create the proper rules and work just fine.

    I think the code needs to be fixed to do that whenever the permalink structure is changed.

  8. annehill
    Member
    Posted 8 years ago #

    Where are the rewrite_rules located in the database? I have this problem on my site, and it is driving me crazy. Not only can no one comment on posts, but all my archives are inaccessible since I tried to change the permalink structure.

  9. annehill
    Member
    Posted 8 years ago #

    In the interest of getting the best response possible to my situation, I have my blog hosted on my ISP which had me place the .htaccess file in the main website directory rather than the blog subdirectory, for security reasons. (I don't know the explanation, but it involved a cgi file as well, I just followed their suggestions.) Anyway, all was running fine in the last version of wp.

    After upgrading to 2.0 (following all the back up instructions, etc.) I decided to change the permalink option from the default structure to the one that organizes them by year, month, and day.

    Now when I try to access a month's worth of archives, I get the following:

    >The requested URL /gcblog/2005/10/ was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.<

    No one can post comments either, or they'll get a similar message:

    >The requested URL /gcblog/2006/01/07/bloggers-lament/ was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.<

    I have also found that wp creates an .htaccess file in the main blog directory after I do something like try to change the permalink structure back to where it used to be, or to go into the comments while logged in. Then the site is totally down, and I get a message like the following:

    >Warning: main(/nfs/www/WWW_pages/annehill/gnosiscafe.com/gcblog/wp-config.php): failed to open stream: Permission denied in /nfs/www/WWW_pages/annehill/gnosiscafe.com/gcblog/wp-blog-header.php on line 12<

    Can someone please tell me something to try that might get things working again?

    Thanks very much.

  10. rdlynch
    Member
    Posted 8 years ago #

    I have this same problem using 2.0. .htaccess is not updated at all and every page except the home page gives nice 404 errors.

    I host with Hosting Matters if that makes a difference.

    Above someone mentioned finding the rewrite rules in the DB. Where are they found and could they just be copied to the .htaccess file from the DB?

    I've been struggleing with this for like two hours now and I'm tempted to go get the rewrite rules out of my 1.5.2 .htaccess file.

  11. petit
    Member
    Posted 8 years ago #

    All you would ever want to know about permalinks should be found here http://codex.wordpress.org/Using_Permalinks
    However with WP 2.0 you shouldn't have to write anything at all by hand, just make sure .htaccess is writable by the web server.

    Under "Fixing (.htacess ) Generation issues" it says:

    "Your host might have blocked the SERVER_SOFTWARE variable and this will cause WordPress' .htaccess generation to fail."

  12. ccf
    Member
    Posted 8 years ago #

    @petit Thanks a lot, it worked and I was able to change permalinks

  13. petit
    Member
    Posted 8 years ago #

    @ccf: Good, I'm happy to hear that!
    @All: There should be no information about the permalink structure in the database.

  14. annehill
    Member
    Posted 8 years ago #

    Well, if the codex had all I'd ever want to know about permalinks, I don't think I'd be posting anything here. I have posted pretty specific information here, have asked my isp support folks to check into whether they have things blocked on their Apache server, but so far no one has responded with anything definitive.

  15. petit
    Member
    Posted 8 years ago #

    Well annehill, I was too fast; There's alway more to know :)

  16. creditlovers
    Member
    Posted 8 years ago #

    I contacted my hosting provider and they solved the problem for me. My WP was installd in a subdomain. Here is an excerpt of the conversation that i had with the CSR.

    Dave: In order for .htaccess files to be parsed in the subdomain, AllowOverride <option> has to be set in your apache configuration for that directory:
    Dave: <VirtualHost *>
    Dave: ServerName subdomain.example.com
    Dave: ServerAlias http://www.subdomain.example.com
    Dave: DocumentRoot /var/www/subdomain.example.com
    Dave: <Directory "/var/www/subdomain.example.com">
    Dave: Options FollowSymLinks MultiViews Includes ExecCGI
    Dave: AllowOverride All
    Dave: AddHandler cgi-script .cgi .pl .py .sh
    Dave: </Directory>
    Dave: . I have added it for you and restarted apache.

    My real domain isn't example.com btw, it's just a sample. Hope this helps.

    http://jonathan.radande.com

  17. mjkeliher
    Member
    Posted 7 years ago #

    I directed the support guys at my ISP to creditlover's comment above (http://wordpress.org/support/topic/45677?replies=16#post-309999), and I was told they "made these modifications." Still, links on my WordPress blog aren't working.

    Click on the about-page link, 404. Click on a post title, 404. Click on a comments link, 404. Everything works when I use the default permalinks structure, but I want the "pretty" permalinks. I cannot for the life of me figure out what I need to do to get this working.

    Any ideas? What information can I offer you all that might let someone help me out? Anyone?

    Thanks,
    Mike

  18. ohbejoyful
    Member
    Posted 7 years ago #

    Switching back to default permalinks fixed all my 404s too, thank heaven. My brain had been slowly melting over that one. Now must figure out how to have pretty permalinks without getting the 404s back.

  19. whooami
    Member
    Posted 7 years ago #

    custom permalinks? 404s? ill only 'spam' this post one more time, in this thread,..it worked for me.

    http://www.village-idiot.org/archives/2007/01/07/wordpress-custom-permalinks-and-trackback-404-issues/

  20. ohbejoyful
    Member
    Posted 7 years ago #

    Ooo, that looks interesting. I've got lots of other stuff to work on, but I'll try your solution at some point. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags