WordPress.org

Ready to get started?Download WordPress

Forums

Permalink structure removing part of URL (6 posts)

  1. njbebop
    Member
    Posted 1 year ago #

    Hi all,

    I've been racking my brain over this all day, and am just hitting dead ends.

    I recently did a site migration/update to our site (http://www.raymondleejewelers.net/products), and somehow the permalink rewrite structure got screwy. Whenever a product link is clicked, it used to go to...

    http://raymondleejewelers.net/products/products-page/designer-brandscartier/18k-white-gold-cartier-diamond-heart-necklace/

    now, after the updates and migration, it's pointing to....

    http://raymondleejewelers.net/products/-page/designer-brandscartier/18k-white-gold-cartier-diamond-heart-necklace/

    Note the "products-page" is now just "-page". It appears to be removing the "products" from the url.

    I checked the database and the product_list_url is fine, I even checked the options.php and it is fine there as well. I even dug down into the rewrite classes and could not pinpoint it.

    If anyone has any info on how to fix this, I'd greatly appreciate it.

    Thanks in advance

  2. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Note the "products-page" is now just "-page"

    Yes, it is just -page now. You might have replaced the link that way during migration.

  3. x500.net
    Member
    Posted 1 year ago #

    Is the link echo'ed by the_permalink() function or is it built of custom variables?

  4. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    It's a custom permalink.

  5. x500.net
    Member
    Posted 1 year ago #

    try echo'ing the variable that suppose to contain the 'products' string and see if it's still there.

  6. njbebop
    Member
    Posted 1 year ago #

    Thanks a lot for the replies, it was decided by the powers that be that the "products-page" in the URL be removed. I was trying to keep the same structure as the prior installation.

    However, this opens up a new can of worms. I try to update the URLs in options.php (and directly in the database), and when I update permalinks, they don't work. I disable and re-enable wp E commerce, and the URL reverts back to "products-page" (which is being cut off to "-page" somewhere.

    If you have any ideas, I'd appreciate it. I'll keep digging here on my end.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic