WordPress.org

Ready to get started?Download WordPress

Forums

Permalink Structure Problem (21 posts)

  1. shockwave01
    Member
    Posted 2 years ago #

    I am having trouble in my permalink structure, most of my pages are giving me a 404 or page not found error even the page is exist. Could someone here help me?

    It started when I updated my wordpress version.

    how to change the permalink structure when a wordpress update changes them?

  2. Updating core shouldn't impact permalinks, but try reseting your permalinks anyway: http://codex.wordpress.org/Using_Permalinks

  3. shockwave01
    Member
    Posted 2 years ago #

    What does exactly the reason why I am experiencing this kind of errors?

    Is it from the plug-ins that conflicts with the new version?

    I really tried this stuff but still not working.

    But thanks for the advice.

  4. Try deactivating all plugins and switching to the default twentyeleven theme to start woring out the possible plugins and theme conflicts that may be changing permalinks.

  5. Dirty Bill
    Member
    Posted 2 years ago #

    Same problem. Only non-stock plugin installed is Buddypress and it is disabled. Tried with 2010 and 2011 themes, front page comes up, any link clicked gives a 404 error.

    I run many WP sites including WPMU, first time I've ever had this happen.

  6. Dirty Bill
    Member
    Posted 2 years ago #

    Disabled, then re-enabled mod-rewrite on Apache server - fixed the issue. Not sure why this would work over a restart but mine is solved.

  7. shockwave01
    Member
    Posted 2 years ago #

    I already tried to deactivate all of the plug-ins but it doesn't solve my problem.

    But thanks for the advice. This is my first time to encounter this kind of error and I really don't know how to solve this.

  8. shockwave01
    Member
    Posted 2 years ago #

    I am always getting 404 error all of my post and pages that I made. I already refreshed the permalink structure and changing it but it is still not working.

    Could someone really tells me what is the reason on why I got this kind of problem?

  9. Whi is your web host? What is the site URL?

  10. shockwave01
    Member
    Posted 2 years ago #

    I am using http://godaddy.com/ as my web host and this is my site url http://blog.gourmetitalian.com/

  11. Change to default permalinks (i.e., no permalinks) and save, be sure WP says the changes were saved OK, and see what happens.

    And be sure your menu items actually link to pages; i.e., check all menu links and regenerate the menu if needed.

  12. shockwave01
    Member
    Posted 1 year ago #

    Ok, I alread did everything. I hope this the last advice from you will solve everything of it.

  13. shockwave01
    Member
    Posted 1 year ago #

    It is still not working, I understand my error now. Every time I choose the default set in the permalink structure, the pages and post of my blog is working well but the categories are the one will be getting the 404 error. And if I am going to choose a permalink structure it will give an opposite result, the pages and posts are the one will get the 404 error.

  14. trickenchicken
    Member
    Posted 1 year ago #

    im having the same issue im using Altushost for my provider ive tried cloaked links/no cloaked no plugins/plugins reverting everything to default deleting the htaccess and remaking it etc but all the links on my front page always include my url in them first which results in a 404

    e-cigsnow.com if anyone has any ideas ive talked to my hosting provider they said its a wordpress problem.

    I forgot to mention the external links on other pages work fine its just the front page that doesn't work

  15. @shockwave01: how are you getting to the pages? Check the menu links to be sure they are correct.

    What do you have in:

    WordPress > Settings > General > WordPress address (URL)
    and
    Wordpress > Settings > General > Blog address (URL) ?

    @trickenchicken: don't hijack threads or multipost. Start your own topic and/or stay with one thread: http://wordpress.org/support/topic/permalinks-messed-up-4?replies=3

  16. shockwave01
    Member
    Posted 1 year ago #

    When I am checking my plug-ins, I got this plug-in from the http://yoast.com/, this is the WordPress SEO plug-in. It has its own permalink structure or details and has also its own .htaccess. What you think? Does it affects the default permalink settings of the wordpress?

  17. Deactivate that plugin. Don't use it.

  18. shockwave01
    Member
    Posted 1 year ago #

    So this will be the one give's the error?

    If I am going to deactivate it. I am sure it will affect all of my meta information. Is it ok?

  19. shockwave01
    Member
    Posted 1 year ago #

    WOW!!

    It is working now, THANK YOU SO MUCH for the help!!

    I really owe in you songdogtech.

    The permalink is working normally now.

    Thanks

  20. trickenchicken
    Member
    Posted 1 year ago #

    I am sorry I wasn't trying to hijack anything i wanted to edit what I had said but my children were climbing on me and yea...I apologise

  21. Glad that worked. It's best to stay with simpler SEO plugins, like All in One SEO, and plugins that don't impact permainks.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.