WordPress.org

Ready to get started?Download WordPress

Forums

permalink structure not updating with multiple xampp wordpress blogs (5 posts)

  1. don_piano
    Member
    Posted 4 years ago #

    I am running Xampp locally to build and test some wordpress blogs and ran across a strange problem I have not been able to answer.

    I originally had one wordpress blog and everything was running smoothly. I changed to "pretty" permalinks and had no problems.

    Then I started another wordpress blog in a new directory and this time the permalink structure wouldn't update. I click on the "day and name" permalink radio button, click "save changes" and then it says "permalink structure updated" when it really hasn't been and the default permalink radio button becomes the selected on again automatically.

    This was driving me a little crazy. I did some searching and it would seem to be the problem addressed http://codex.wordpress.org/Using_Permalinks#Using_.22Pretty.22_permalinks and http://www.mydigitallife.info/2006/03/08/wordpress-permalinks-does-not-work-in-xampp-setup/ but these solutions did not fix the problem for me. My original wordpress blog still runs find and the permalinks work and update correctly. But my other ones continue to instantly revert back to the default. I'm not sure why.

  2. don_piano
    Member
    Posted 4 years ago #

    Quick correction to my previous post. I thought the original wordpress blog was running fine and the permalink setting was able to be changed, but that is wrong. Although the permalinks are set to the "pretty" day and name setting, which is what I want, this can not be changed. When (for testing purposes) I click on the "default" permalink radio button and click "save changes" the "day and name" radio button remains selected. Not sure why.

  3. don_piano
    Member
    Posted 4 years ago #

    Ok, disregard all that - I'm a schlep and had javascript turned off, haha. Now it works great!

  4. thedayofgames
    Member
    Posted 4 years ago #

    I am told my "Permalink structure updated."

    But I still can only use Default. Even the other selections say
    "Permalink structure updated." but do not work.

    What is the deal with Javascript? How would I manage that?

  5. thedayofgames
    Member
    Posted 4 years ago #

    Fixed -

    Modify the Permalink code to "Custom" and add /index.php/ to the front

    ----------------------------------------------------------------
    If this isn't an option, you can try PATHINFO permalinks; put index.php/ at the start of your custom permalink structure:

    /index.php/%year%/%monthnum%/%day%/%postname%/
    --------------------------------------------------------------------

Topic Closed

This topic has been closed to new replies.

About this Topic