WordPress.org

Ready to get started?Download WordPress

Forums

Permalink structure not updating (11 posts)

  1. iM1
    Member
    Posted 6 years ago #

    When I set the permalinks to defaults settings the site works fine without any 404's. Its when I then change it to date and name based (or any other permalink settings) that it brings the 404 pages on my whole blog except for the homepage.

    I thought then maybe it the .htaccess file that hasnt been updated but it has. When I press update settings on the permalinks menu it says "Permalink structure updated."

    So why isnt it allowing me to change the permalinks structure?

  2. moshu
    Member
    Posted 6 years ago #

    Try the troubleshooting section on this page: Using_Permalinks

  3. iM1
    Member
    Posted 6 years ago #

    What should I be looking at in the troubleshooting section?
    The .htaccess file has been updated with the mod-rewrite.

    Any other ideas? Or is there something I missed?

  4. moshu
    Member
    Posted 6 years ago #

    The .htaccess file has been updated with the mod-rewrite.

    That's not entirely correct.
    The .htaccess file (as a file) can be "updated" by WP if it is writable. However, it doesn't mean that mod_rewrite and AllowOverride is enabled on your server, for example.

  5. iM1
    Member
    Posted 6 years ago #

    Ok so what do I need to do?

  6. iM1
    Member
    Posted 6 years ago #

    Could someone please help! :-(

  7. iM1
    Member
    Posted 6 years ago #

    Permalinks did work at one point. When I first got the host and they gave me a temporary URL (untill i got my own domain) the "Date and Post name" permalink structure did work.
    Its only once I got my .net domain that the permalinks didnt work, Only the DEFAULT permalinks worked.

  8. iM1
    Member
    Posted 6 years ago #

    Why isnt no one helping? I've tried everything I could think of but nothing is working. :-(

  9. moshu
    Member
    Posted 6 years ago #

    Maybe people have a life outside of these forums... All the helpers around here are volunteers.

  10. iM1
    Member
    Posted 6 years ago #

    If everyone here is volunteering to help why dont they help me.

  11. modifiedcontent
    Member
    Posted 6 years ago #

    I have the same problem. I have WordPress installed in a /blog folder. Including WP posts in the index.php at the root works fine.

    But then when I turn on Permalinks, I get 'Sorry, no posts matched your criteria' on the homepage.

    Is there an "official" solution by now?

Topic Closed

This topic has been closed to new replies.

About this Topic