WordPress.org

Ready to get started?Download WordPress

Forums

Permalink structure no longer works! (61 posts)

  1. dannymoe34
    Member
    Posted 2 years ago #

    I agree. What is the fix for this thing? and also this fix must to be fixed on next WP release. This is huge problem who can hurt to the seo.

  2. Russell Jamieson
    Member
    Posted 2 years ago #

    The following is a temporary fix until WordPress fix this serious bug in their permalink handling:

    Add a couple of lines to your .htaccess file after the RewriteBase line

    RedirectMatch 301 ^/(\d+)/$ http://www.yoursite.com/?p=$1
    RedirectMatch 301 ^/(\d+)$ http://www.yoursite.com/?p=$1

    This matches URLs ending in /%%post_id or /%%post_id/ and redirects to the correct post

  3. dannymoe34
    Member
    Posted 2 years ago #

    Russel, I can't use .hataccess file because I have IIS server. You know how to do it with web.config file?

    Also with this problem I stuck with wordpress and can't continue with my website. I want to change permalinks from the default example.com/blog/?p=123 and moving it to the root so I can use example.com/page-name for pages. But what I will do with my old permalinks? I have active blog with a lot of posts. This is a serious problem of wordpress.

  4. Russell Jamieson
    Member
    Posted 2 years ago #

    Danny, I do NOT have IIS so I cannot test this - but it will look a little like this....

    <rewrite>
      <rules>
        <rule name="Redirect1" stopProcessing="true">
          <match url="^/(\d+)$" ignoreCase="false" />
          <action type="Redirect" redirectType="Permanent" url="http://www.yoursite.com/?p={R:1}" />
        </rule>
        <rule name="Redirect2" stopProcessing="true">
          <match url="^/(\d+)/$" ignoreCase="false" />
          <action type="Redirect" redirectType="Permanent" url="http://www.yoursite.com/?p={R:1}" />
        </rule>
      </rules>
    </rewrite>
  5. sashen
    Member
    Posted 2 years ago #

    THANK YOU RUSSELL!

    Worked like a charm for me.

    Let's see when WP actually fixes it.

  6. taropaa
    Member
    Posted 2 years ago #

    @Russell Jamieson I tried it and unfortunately that didn't fix it for me.

  7. dannymoe34
    Member
    Posted 2 years ago #

    Thank you Russel but I don't think it's possible to fix it via hatacces or web.config. If I change the permalinks from example.com/blog/?p=123 to example.com/blog/post-name ,Someone must fix this issue on wordpress files.

  8. Russell Jamieson
    Member
    Posted 2 years ago #

    Hi Danny, Yes let's hope WP gets this fixed in the next release

  9. dannymoe34
    Member
    Posted 2 years ago #

    Someone need to report this problem to wordpress developers team

  10. taropaa
    Member
    Posted 2 years ago #

  11. dannymoe34
    Member
    Posted 2 years ago #

    Someone know what is the function who control this redirect? Maybe we can restore it from the old version and offer to the others in meantime

  12. RoxyJo
    Member
    Posted 2 years ago #

    Just wanted to say that I am having the same issue. The default permalink structure works, but the postname permalink structure does not work, this seems to happen to newly added sub- pages..

  13. dannymoe34
    Member
    Posted 2 years ago #

    RoxyJo, you have IIS server?

  14. rcbrothers1
    Member
    Posted 2 years ago #

    Updated SQL, deactivated all plug-ins, then upgraded to wp3.4. Immediately following upgrade, all inbound links to posts are broken: "The page isn't redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete."

    Very "plain vanilla" site, minimal plug-ins and only the customization options provided within the wp setup.

    Site
    http://market-intel.com/blog
    Example of broken link:
    http://market-intel.com/blog/2012/06/11/better-marketing-starting-tomorrow/

    I'm only modestly proficient with wp's internal code, so a solution that a lay-person can handle would be appreciated.

  15. RoxyJo
    Member
    Posted 2 years ago #

    Hi dannymoe34,
    no the server is a linux server (can they be iis, or is it only windows?)

    rcbrothers1:
    Try changing your permalinks to default, and then back again to custom.

  16. dannymoe34
    Member
    Posted 2 years ago #

    i found this ticket http://core.trac.wordpress.org/ticket/10187
    The permalinks was fixed on IIS for pervious versions of wordpress but why it's not working now? in 3.4 it doesn't work

  17. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    I agree with RoxyJo, but first deactivate all plugins and switch to default theme to rule them out... then, switch back to default permalink (look at this page for error messages) save (then log out and run the site!!!), then log back in and switch to your permalink setting...save (then log out again and browse to site)...the site needs to be run with new settings (not on localhost)

  18. dannymoe34
    Member
    Posted 2 years ago #

    Please if someone know how to fix this problem, I belive that many users use iis so it can help to them also

  19. dbramley
    Member
    Posted 2 years ago #

    Just to jump in with a similar issue since upgrading;

    I use mysite.com/categoryname/post/ which works fine before upgrading.

    I have the category base set to '.' so that I can access categories by visiting mysite.com/category

    All was working fine. As soon as I upgrade category base no longer works so that I can't access mysite.com/categoryname any more. Removing the '.' will result in mysite.com/category/categoryname which does work but it obviously wrong for my site.

    I'm on ISS and have tried this with a brand new install, no plugs too and it doesn't work.

    Thanks

  20. dannymoe34
    Member
    Posted 2 years ago #

    dbramley, what about your old permalinks? the redirect from the old ones to the new works without a problem?

  21. pmtjohnson
    Member
    Posted 2 years ago #

    dbramley, I have exactly the same problem as you, with '.' in the category base. I don't want to remove the '.' (which does resolve the problem, but clearly changes the links - I guess I'd have to setup a bunch of 301 redirects for all my categories). Maybe this is the only way until they fix the problem ??

  22. dannymoe34
    Member
    Posted 2 years ago #

    pmtjohnson, it's not good for seo.

  23. rcbrothers1
    Member
    Posted 2 years ago #

    Thanks, RoxyJo, but nothing mentioned here has fixed my broken links problem.
    Any way to revert back to a previous version of WP? Likely to help?

  24. dannymoe34
    Member
    Posted 2 years ago #

    rcbrothers1, I also search for soloution for this problem

  25. rcbrothers1
    Member
    Posted 2 years ago #

    From another forum ...
    This didn't work for me, but it apparently has solved the broken links problem for some people
    http://webcomicms.net/support/wordpress-3-4/

    "Try changing your Permalink setting to Default and then back again, possibly a few times. This should force WordPress to clear out the permalink rewrite cache. If that doesn’t work, try adding this to your theme functions.php file:
    flush_rewrite_rules();
    and then visiting any page on your site. This should also force WordPress to clear out the permalink rewrite cache. Don’t leave that in your functions.php file, however."

  26. dannymoe34
    Member
    Posted 2 years ago #

    this is not the soulution for this problem, the redirect still not working

  27. dannymoe34
    Member
    Posted 2 years ago #

    http://core.trac.wordpress.org/ticket/21020 this fix will be in the next wordpress release? if yes, anyone tried it on IIS?

  28. dannymoe34
    Member
    Posted 2 years ago #

    Update: I installed a fresh version on linux server and tried this fix on the ticket but it doesn't work

  29. rcbrothers1
    Member
    Posted 2 years ago #

    1. As of Sunday night, my site seems to be working again, set on default permalink structure and default formats. Many times over several preceding days, I toggled back and forth between permalink and format options, so I suspect it wasn't my actions that solved the problem.
    2. Looks as if WP have probably found and fixed a bug - there's a new warning box on the wp settings page that directs you to activate the "customizable permalinks" plugin before de-selecting the default permalink structure.
    3. However, even with the plug-in activated, I can't get past the warning box.

    In any case, thank WP pros to doing whatever you did!

  30. rcbrothers1
    Member
    Posted 2 years ago #

    Well, not entirely fixed ...
    Remotely requested links to individual posts (posts that were created with an optional permalink structure) connect to the front page of the blog, not to the requested post.

Topic Closed

This topic has been closed to new replies.

About this Topic