WordPress.org

Ready to get started?Download WordPress

Forums

Permalink settings page not displaying (11 posts)

  1. doctor-manhattan
    Member
    Posted 4 years ago #

    Help!

    Just started using WordPress, and have set up a blog website here

    Everything was working tickety boo until I started playing with the Permalinks option. Tried a few custom options which worked OK, but not as I wanted. The last option I tried was
    /%postname%/
    Once I had saved this change, all my pages and posts now result in a 404 error page, and worse still, my Permalinks settings page is no longer displayed in wp-admin!

    All of the other settings (such as General, Writing, Reading, Discussion etc) display just fine, but the Permalink page is just blank!

    Can anyone help me unbreak my site?

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Ftp into your server and delete, or rename, the .htaccess file in your root WordPress folder.

  3. doctor-manhattan
    Member
    Posted 4 years ago #

    OK, I've done that bit - doesn't seem to have made any difference....

  4. alism
    Member
    Posted 4 years ago #

    Yer in safe hands with esmi, but it might also be worth clearing your cache/trying a different browser and having another go at:
    http://www.doctorwhodvds.info/wp-admin/options-permalink.php

  5. doctor-manhattan
    Member
    Posted 4 years ago #

    Thanks for the tips - have cleared cache (Firefox 3.5.5) and tried IE8, but still no joy.

    Not sure about .htaccess file - what is it used for and what would deleting it do?

  6. makepretty
    Member
    Posted 4 years ago #

    I have the same problem here... Help!

    :(

  7. alism
    Member
    Posted 4 years ago #

    http://en.wikipedia.org/wiki/Htaccess

    Are you sure you deleted/renamed it right? Otherwise, deactivate your plugins, just to rule out a conflict there.

  8. doctor-manhattan
    Member
    Posted 4 years ago #

    Sorted!

    Thanks for the advice alism - I deactivated all my plugins, and lo and behold, I could access my Permalinks config screen again. So I reset the permalinks to default and my site was up and running again. I've since reactivated all the plugins again and all seems fine.

    Unfortunately, I didn't take the scientific approach and deactivate the plugins one by one, so I don't know which one was causing the conflict.

    Does make me wary of using Permalinks again though.....

    Thanks also to esmi for your initial suggestion.

    Thanks guys!

  9. Shane G.
    Member
    Posted 4 years ago #

    Hi,

    Set your desired permalink and add this code in htaccess;

    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Thanks,

    Shane G.

  10. doctor-manhattan
    Member
    Posted 4 years ago #

    Shane G. you are a superstar!

    Added your code into .htaccess and it worked a treat. Posts and pages now have "pretty" URLs, and I still have access to the Permalinks settings page.

    Thank you so much!

    Not sure what the code is doing though - any chance of a quick walkthrough?

  11. Pali Madra
    Member
    Posted 3 years ago #

    Hey guys,

    Thank you for the answers.

    I have come across a similar problem where I cannot see the permalink page. I will try the .htaccess trick.

    I wanted to know if someone knows why editing the .htaccess file fixes the problem?

    Thanks in advance.

Topic Closed

This topic has been closed to new replies.

About this Topic