WordPress.org

Ready to get started?Download WordPress

Forums

"Permalink Settings" page is Blank - WP 2.9.2 (24 posts)

  1. asingh
    Member
    Posted 4 years ago #

    Hi everyone,
    - This is my first wordpress install and I am experiencing problems in changing my permalink settings to "pretty permalinks". The "Permalink Settings" page is blank. Can someone please offer pointers to help me out?

    Problem:
    - This is a wordpress install running on a hosted Linux/Apache web server / WP 2.9.2 installed.
    - When I visit the "http://abhijitanand.com/testblog/wp-admin/options-permalink.php" page, I get a blank page - The sidebar is loaded but the page is blank - This means I can't update my permalink settings.

    Troubleshooting Done so far:
    - Googled around and saw that this is a common problem. Here's a link to someone else asking for help on the exact same issue (Screenshot included):
    http://wordpress.org/support/topic/348950?replies=5
    - Contacted the support team of my Web Hosting provider (eWebGuru.com) asking them if mod_rewrite and apache_get_modules are enabled. They confirmed that they are.
    - When this page loads in IE-8, I get an "error on page" and I see this error in the browser's error console:

    Message: 'null' is null or not an object
    Line: 50
    Char: 1
    Code: 0
    URI: http://abhijitanand.com/testblog/wp-admin/options-permalink.php

    - When it loads in Firefox, I get this in the error console:

    structure is null Line 50
    URI: http://abhijitanand.com/testblog/wp-admin/options-permalink.php

    - I'm not a developer and I don't know how to proceed further here - can some one please help me out?

    - Lines 59 and 50 for options-permalink.php are:
    var structure = document.getElementById('permalink_structure');
    structure.onfocus = function () { document.getElementById('custom_selection').checked = 'checked'; }

    Regards,
    Abhijit

  2. Samuel B
    moderator
    Posted 4 years ago #

    why not upload the /wp-admin folder again - sounds like you may have gotten a bad file(s)

  3. asingh
    Member
    Posted 4 years ago #

    @Samboll -
    -- Thanks for your reply.

    -- I've done the below steps more than once now:
    1. Deleted the installation.
    2. Made sure that it Removed the MySQL Database.
    3. Made sure that all the WP folders were gone from the public_html folder.
    4. Re-ran the WordPress auto-install script (fantastico).

    -- Still, after the install finishes - I experience the same issue - Only the Permalinks page fails to load correctly - thus not allowing me to change the setting. All other pages in the dashboard open.

  4. Samuel B
    moderator
    Posted 4 years ago #

    maybe try one of these

    1. Try adding this line to your wp-config.php file:
    define('WP_MEMORY_LIMIT', '64M');
    
    2. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)
    
    3. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M
  5. Mark / t31os
    Moderator
    Posted 4 years ago #

    You could also try installing manually, ie. Not using the Fantasico installer.

    You seem confident and able enough, why bother with the Fantastico installer?

  6. Samuel B
    moderator
    Posted 4 years ago #

    Fantasico installer

    I wish that software had never been developed.

  7. asingh
    Member
    Posted 4 years ago #

    @samboll -

    Thanks for continuing to offer me help.

    <<1. Try adding this line to your wp-config.php file:
    define('WP_MEMORY_LIMIT', '64M');>>

    Abhi - Added the above line right below the "<?php" in wp-config.php

    <<2. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)>>

    Abhi - I've enabled the "Show Hidden Files" view in the cPanel file manager, but can't see this file anywhere under the WWW document root. Is there another place where I should be looking?

    <<3. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M>>

    Abhi - Done. Still no joy.

    @t31os_

    -- Thanks for the suggestion of performing a manual install.
    -- I just finished the following steps:
    1. Downloaded WordPress from http://wordpress.org/download/
    2. Followed the steps mentioned at http://codex.wordpress.org/Installing_WordPress to install wordpress @ http://abhijitanand.com/blog1
    3. Tried the above suggestions offered by samboll.

    -- The install was successful - the WP-Admin opens- but the exact same problem (structure is null error / blank page) still exists when I access the page at http://abhijitanand.com/blog1/wp-admin/options-permalink.php

  8. asingh
    Member
    Posted 4 years ago #

    Second try. Thanks.

  9. Mark / t31os
    Moderator
    Posted 4 years ago #

    Did you use the same database in each instance, or did you use a fresh database each time?

    You could try flushing out your permalink settings in the database(if they're still present from when you set them initially) and see if that allows the page to come back (i can explain how).

    Do you have access to phpmyadmin?

    Some members reported fixing problems loading the permalink page by flushing the permalink option, and it appears you had access prior to setting them, so this could help in your case.

    To skip past the explanation phase though take a look at this thread here.
    http://wordpress.org/support/topic/356829?replies=25

  10. asingh
    Member
    Posted 4 years ago #

    @t31os_

    <<Did you use the same database in each instance, or did you use a fresh database each time?>>

    Abhi - Fresh database each time.

    <<You could try flushing out your permalink settings in the database(if they're still present from when you set them initially) and see if that allows the page to come back (i can explain how).>>

    Abhi - I think they're already flushed (see below). Please do explain if more steps need to be followed.

    <<Do you have access to phpmyadmin?>>

    Abhi - Yes

    <<To skip past the explanation phase though take a look at this thread here.
    http://wordpress.org/support/topic/356829?replies=25>&gt;

    Abhi - Thanks for that link.

    For me the option_value is already blank and I've already tried setting the option_id to zero.

    Here's what I did after reading the posts in that link:

    1. Deleted the wordpress sub-directory. Deleted the MySql database and the MySql user using the "MySql Databases" tool in cPanel. Ensured that PHPMyAdmin was clean (i.e. it read "no databases").

    2. Did a fresh install of WP 2.9.2. Faced the same issue of the "options-permalink.php" page being blank (sans the line on the top).

    3. I then went into PHPMyAdmin --> wp_options --> Browsed to permalink_structure.
    - Noticed that the "option_value" textbox was blank (per the posts on that link, i think it needs to be that way?)
    - The value for option_id was set to 32 -- I set it to 0 and saved :No joy. Set it back to 32 / different 'unique values' - back to 32.
    - Tried entering multiple different values in option-value - No difference - the page still won't load. For some settings - It went completely blank.
    - Went to PHPMyAdmin --> ProcessList and restarted the thread - no difference.

    Thoughts?
    Thanks for continuing to help me fixing this.

    /Abhi

  11. Mark / t31os
    Moderator
    Posted 4 years ago #

    I must admit i'm stumped as to why that page would be blank.

    I'd have to assume at this point it's specific to your host(i could be wrong of course), this is why i linked to the other thread, in the hope you'd find the solution.

    Ask your host if they run mod_security, and if so whether it's possible to disable it on your site for testing (if they ask why, explain the problem you're having, they might be able to offer advice or suggestions on a cause). If you can do that, it may help. I can't see why mod sec would block requests to that page specifically but it's one possible cause(as a wild guess). Of course if they don't run mod sec, then i guess it's not the cause.

  12. asingh
    Member
    Posted 4 years ago #

    I'll get in touch with my host on whether they've disabled mod_sec.

    I have one more question if that's okay -- There's nuthing stopping me from "Setting this value directly in the database", right? I mean -- If the frontend isn't letting me edit the page -- I can always do it that permalink_structure field in MySql?

    Also, If I do this change in the db, should all previous posts also get affected to reflect the new url scheme?

  13. Mark / t31os
    Moderator
    Posted 4 years ago #

    Honestly i could'nt say for sure, in theory you could, but i'm not entirely certain it's a case of just updating one setting, the rewrite rules array would need to be generated, and i don't think that will happen by updating that setting alone.

    Come to think of it, i'm pretty sure that wouldn't work, nice idea though..

  14. budinsky
    Member
    Posted 4 years ago #

    You sure can do it manually. I am trying to find out why the page is blank too, but in the mean time I have manually altered the setting in PHPMyAdmin.

    1. Go in to PHPMyAdmin
    2. In the sidebar on the left select wp_options
    3. Go to Page number: 2
    4. click the pencil on the link with permalink_structure
    5. In the big box next to option_value and input /%postname%

    It works on my site http://www.desirableweddings.com/backyard-weddings

  15. dnnsldr
    Member
    Posted 4 years ago #

    @budinsky and @asingh
    Had the same issue and was able to resolve it using @budinsky method of going into PHPMyAdmin and adding the option_value to the permalink_structure. Thanks for the tip!

  16. Stedy
    Member
    Posted 3 years ago #

    Asingh, did you ever get this resolved?

    I too am having the exact same issue. I have completely removed everything (except the cpanel files) from my domain and each fresh install (manual or fantastico) has the blank permalinks page right from the start. I have 5 other wp blogs hosted by the same people and none of them have the issue.

    I've emailed my host to see if anything can be done. Will advise if successful.

  17. nathanloehlein
    Member
    Posted 3 years ago #

    Try and check if your .htaccess file exists and is correctly set up.

  18. Fifi
    Member
    Posted 3 years ago #

    After I upgraded to WordPress 3.0 the "Permalink Settings" page was blank in my WordPress Admin Panel.

    Fixed that updating the following:

    1. Navigated to ../wp-admin/includes/misc.php

    2. Commented the second line under "function got_mod_rewrite ()"

    OLD:

    function got_mod_rewrite() {

    $got_rewrite = apache_mod_loaded('mod_rewrite', true);

    return apply_filters('got_rewrite', $got_rewrite);
    }

    NEW:

    function got_mod_rewrite() {

    //$got_rewrite = apache_mod_loaded('mod_rewrite', true);

    return apply_filters('got_rewrite', $got_rewrite);
    }

    3. ../wp-admin/options-permalink.php - shows up.

  19. coreweb1
    Member
    Posted 3 years ago #

    @Fifi --- there appears to be no /wp-admin/includes/misc.php in 3.0 -- must have been leftover from the 2.x series in your install. Its not in my 3.0 (clean) install anyway.

    I have same problem and can make the adjustments in MySQL as mentioned above -thanks budinsky -

    But a solution as to why this admin page is not showing is still unresolved. Maybe hosting/ PHP version issue? It would be great if one of you PHP wizards could solve it. thanks.

  20. sotrix
    Member
    Posted 3 years ago #

    I have the same problem

    Switched hosts and now .../wp-admin/options-permalink.php is blank

    Firebug shows this error when loading the options-permalink.php page:

    structure is null
    structure.onfocus = function () { document.getElementById('custom_selection').checked = 'checked'; }
    options-permalink.php (line 63)

  21. bellafaith
    Member
    Posted 3 years ago #

    After a new installation of 3.0.1, I was having the same issue. This post said to comment out the following groups of code in wp-admin/options-permalink.php and it solved my problem:

    Around line 92:

    if ( ! got_mod_rewrite() && ! $iis7_permalinks )
    	$prefix = '/index.php';

    Around line 153:
    $wp_rewrite->flush_rules();

  22. Melanie
    Member
    Posted 3 years ago #

    Had this problem, worked through the suggestions, etc.

    Fifi's advice worked perfectly...Thanks

  23. iMenn
    Member
    Posted 3 years ago #

    Thanks @Fifi, too. I had this problem and solved by Fifi's advice.

    I use name.com hosting, installed WordPress 3.0 by fantastico but click on Update to 3.0.1 manually.

    but when go to Permalink menu, I found these choices instead,

    Default: http://www.alwaysbeside.com/?p=123
    Day and name: http://www.alwaysbeside.com/index.php/2010/09/07/sample-post/
    Month and name: http://www.alwaysbeside.com/index.php/2010/09/sample-post/
    Numeric: http://www.alwaysbeside.com/index.php/archives/123

    But I just ignore /index.php/ and use this,

    /%year%/%monthnum%/%postname%/

    It worked :)

  24. lost_in_wp
    Member
    Posted 3 years ago #

    Hi, just a quick note to say that I had also had the same problem - second page of the WP installation and the permalinks page were both blank. I got in contact with my host and they fixed it but why or how this works I have no idea... The response was "I just created an empty phi.ini file and put it on your admin folder."

    So there you go.

Topic Closed

This topic has been closed to new replies.

About this Topic