WordPress.org

Ready to get started?Download WordPress

Forums

Permalink Settings has index.php in path (9 posts)

  1. cupboy2013
    Member
    Posted 1 year ago #

    On my local computer everything is ok, but on the web hosting site the Permalink Settings are wrong.

    For example:

    says this: http://www.xxx.com/wp1/index.php/sample-post/

    should be this: http://www.xxx.com/wp1/sample-post/

    I need to eliminate index.php from the path. What is causing it to appear? My guess is the hosting company removed the IIS7 url rewrite module. Any other ideas?

  2. Christof
    Member
    Posted 1 year ago #

    check settings -> permalinks. what option is enabled?

  3. cupboy2013
    Member
    Posted 1 year ago #

    Post Name

    I can go to Custom and remove index.php from the path but then I get page cannot be found.

  4. Christof
    Member
    Posted 1 year ago #

    Hmmm very strange.. I had permalinks issues myself last week but found a solution installing the 'Core Tweaks WordPress Setup' plugin.. Mebe it works for you? Please let me know!

  5. Dzynit
    Member
    Posted 1 year ago #

    Core Tweaks will just set the permalinks for you if the htaccess file is writable from a single page where you can bulk set most of your wordpress settings at one time. Which is mostly meant for new installs.

    You're likely right cupboy2013, that the rewrite rules have been removed. Did you try just setting the permalinks again? Set them back to a default setting once then set back to your preferred setting. If they're still not working, do you have ftp access to check the htaccess file to see if the rewrite rules are being added?

    Otherwise, you might need to put in a support ticket with your hosting to get help with it. Some IIS hosting will not work with the permalinks not using the index.php in the url. But if they were working before, you should be able to set the reset the rewrite rules to have them start working again.

  6. Hendison Scott
    Member
    Posted 1 year ago #

    Yes, like @Dztynit I'd also recommend that you do *not* use Core Tweaks, as it's primarily for a new WP installation. I'm glad @christof15 likes it, but solving this problem is something it likely won't do, and it MAY screw up other stuff too...

    Regarding your index.php problem, Godaddy does that too, shoving index.php into the URL. If that's your host, contact them for removal.

  7. cupboy2013
    Member
    Posted 1 year ago #

    I've reopened the ticket with dotster. They came up with an answer last time that didn't help me. Something about an httpd.ini file but I've never seen that file.

  8. cupboy2013
    Member
    Posted 1 year ago #

    Not getting any help from dotster. Is it at all possible the problem is on my end? Everything is fine on my localhost version. Is this problem rare? I'm surprised the makers of WordPress have no solution for this. My guess is lack of support for Windows, which is typical in the PHP world.

  9. jodzeee
    Member
    Posted 1 year ago #

    I was just looking into this issue as well. Is your site hosted on a Windows server instead of Apache? See article here: http://codex.wordpress.org/User:ringmaster/IIS#Alternate_Rewrite_Methods

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags