WordPress.org

Ready to get started?Download WordPress

Forums

Permalink screwy-ness (10 posts)

  1. andytford
    Member
    Posted 5 years ago #

    I'm using the Skyye-News template in which the index.php has one line of code: <?php get_template_file('home.php'); ?>

    When I go to change the Permalinks custom structure to: %postname%, the links are thrown off completely. Instead I have to use: /index.php/%postname%/

    Is this due to an issue with index.php having this home.php? or should I use the standard loop to resolve?

    Not sure what's causing this as I've never ran across it before.

    Thanks in advance to anyone willing to assist~

  2. andytford
    Member
    Posted 5 years ago #

    I don't think I clearly stated what I'm trying to do, so let me back up.

    I would like to change the Permalink to a custom structure, as I've done many, many times before by simply inserting /%postname%/. For whatever reason this isn't working and index.php is required before /%postname%/ ? This doesn't make sense and furthermore doesn't make the Permalink structure pretty either - which is the whole point of what I'm trying to do.

    So I inserted the Loop code from the 'Classic' theme's index.php file and got nowhere with it. For whatever reason /index.php is required (or by default if using one of the other custom structures) for any of the Permalinks to work.

    This is not the case if I were to leave it as-is with the default structure of say ?p=1 or ?cat=1.

    I'm at a loss as to where this problem originates...or how to solve it.

    Thanks again to anyone willing to assist.

  3. esmi
    Forum Moderator
    Posted 5 years ago #

    That sounds like a poor theme to me. I'm not surprise it has problems. Do you have an category.php or archive.php file in the theme? That might make a better starting point for a new index.php file.

  4. andytford
    Member
    Posted 5 years ago #

    I do have category and archive in the theme and those work just fine. Could this possibly be a server setting?

  5. equaldesign
    Member
    Posted 5 years ago #

    Are you using a windows server? If so Windows server do not have the mod_rewrite function which apache uses to rewrite your 'pretty' URLs. Therefore the only way it shows them is by putting index.php and then your permalink structure.

    There are some work arounds but in my experience they are hit and miss. See link below:

    http://codex.wordpress.org/Using_Permalinks#Permalinks_without_mod_rewrite

  6. EMG
    Forum Volunteer
    Posted 5 years ago #

    I think this is a server setting, actually. Perhaps something in your .htaccess settings?

    Because I just downloaded and installed the same theme and my pretty permalinks are still pretty, even with the home.php include.

    Check the Codex for more information about permalinks and .htaccess and see if maybe there's something there?

    If I can find some specifics I'll post and give more direct information.

    EDIT: Or what equaldesign said! :)

  7. andytford
    Member
    Posted 5 years ago #

    All signs point to the mod_rewrite issue (including straight from the hosting company's mouth - errr, I mean support ticket). I'll be researching this a bit more, but wanted to document this for anyone else who runs into the same issue.

    Question: Where, or how, do I locate the "web.config file in the WordPress folder"? I have basic FTP access and am not sure where I need to look...

    Thanks in advance to anyone willing to help ~

  8. andytford
    Member
    Posted 5 years ago #

    I create a web.config file with the following markup:

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
      <system.web>
    
      <rewrite>
        <rules>
            <rule name="Main Rule" stopProcessing="true">
                <match url=".*" />
                <conditions logicalGrouping="MatchAll">
                    <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
                    <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
                </conditions>
                <action type="Rewrite" url="index.php" />
            </rule>
        </rules>
    </rewrite>
    
    </system.web>
    </configuration>

    Uploaded it to the root of the site and adjusted the Permalinks to %postname% but am still unable to get this to work properly. What am I doing wrong?

  9. andytford
    Member
    Posted 5 years ago #

    The hosting company is now telling me that

    this server is using Helicon ISAPI Rewrite 3. You will need to put your rewrite rules in .htaccess

    I have my head up my derriere when it comes to this kind of stuff. Does anyone know how I would adjust my .htaccess for Helicon ISAPI Rewrite 3?

    Thanks again to anyone willing to help ~

  10. andytford
    Member
    Posted 5 years ago #

    I inserted the following in the .htaccess file:

    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule .* /index.php [L]

    Changed the Permalinks back to: %postname%

    I downloaded and activated the ISAPI Rewrite plugin. Still no go? Also, after I uploaded the modified .htaccess file, it thwarted my CSS, which went non-existent.

    WTF????

Topic Closed

This topic has been closed to new replies.

About this Topic