WordPress.org

Ready to get started?Download WordPress

Forums

Permalink problems, hope someone can solve them. (10 posts)

  1. ghanes14
    Member
    Posted 6 years ago #

    Yesterday I posted asking for help to get them working again. I found a way to get them to work (setting to default). But I have a couple things I need solved.

    1. Even though it's set to defult, when I goto my site my posts are still showing in the custom permalink which when I click just takes me back to the home page (or shows 404 error in default theme).

    2. All the links I have posted around to my posts (and in google search) are for my custom permalinks, which when people click will do the same thing, and I need to get this fixed.

    I have searched and read until late last night and I can't find anything on why permalinks would suddenly stop working. Any ideas?

  2. ghanes14
    Member
    Posted 6 years ago #

    No one? I just noticed that it's not just pretty permalinks to my posts, the RSS links in the footer, and in the header no longer work. When I click them instead of it taking me to the feedburner page like it's supposed to, it takes me back to the front page of my site.

    HELP ME I'M GOING NUTS!!! 0.o

  3. iridiax
    Member
    Posted 6 years ago #

    Try emptying your browser cache. Are you using a WordPress caching plugin? These can sometimes cause recent site changes not to show. Also, go to your permalinks settings and click Save Changes even if you haven't changed anything.

  4. ghanes14
    Member
    Posted 6 years ago #

    I disabled the cache, and the changes I made to the sidebar finally showed up! That's one thing out the way.

    I tried switching back to the date and name custom permalink and it did the same thing, send me back to the front page when clicking the link. The RSS buttons still send me to the front page now as well, even though clicking the posts doesn't (when permalink is set to default).

    You can test and see if it sends you back to the front page as well, it should take you to the feedburner page (but don't for me). http://all-notions.com

  5. iridiax
    Member
    Posted 6 years ago #

    Everything works fine for me on your site (Firefox on a Mac), so it may be a problem with your web browser still showing old cached data.

  6. ghanes14
    Member
    Posted 6 years ago #

    Weird, I have tried it with several browsers, IE, Firefox, Safari, and Opera. It still bugs me why it won't work with date and name type permalinks, but I guess i'll leave it on default and post those links from now on.

  7. ghanes14
    Member
    Posted 5 years ago #

    The RSS feeds still do not work and I have had several people test them out for me. Also custom permalink still will not work!

  8. iridiax
    Member
    Posted 5 years ago #

    Are you using Yahoo! web hosting?

    Oops, look at the generated feed href in your page source code:

    <link rel="alternate" type="application/rss+xml" title="All-Notions RSS Feed" href="All-Notions" />

    Make sure that you have this in the head section of your theme's header.php:

    <link rel="alternate" type="application/rss+xml" title="<?php bloginfo('name'); ?> RSS Feed" href="<?php bloginfo('rss2_url'); ?>" />

    And then in the Dashboard, check your WordPress address (URL) and Blog address (URL). Also check your feedburner settings.

  9. ghanes14
    Member
    Posted 5 years ago #

    <link rel="alternate" type="application/rss+xml" title="<?php bloginfo('name'); ?> RSS Feed" href="<?php bloginfo('rss2_url'); ?>" />

    Is in the header.php. After making sure I checked the source code again and it showed:

    <link rel="alternate" type="application/rss+xml" title="All-Notions RSS Feed" href="All-Notions" />

    Is the href= supposed to be showing the feedburner link?

  10. ghanes14
    Member
    Posted 5 years ago #

    I was going to try and delete the feed and remake it incase that did anything as I only have a few subscribers. But when I clicked create feedburner feed in the options>feedburner plug-in it showed:

    The URL you entered does not appear to be a valid feed. We encountered the following problem: Error on line 2: The processing instruction target matching "[xX][mM][lL]" is not allowed.

    Not idea what that means...

Topic Closed

This topic has been closed to new replies.

About this Topic