WordPress.org

Ready to get started?Download WordPress

Forums

Permalink Problems, 404 Errors - maybe htaccess ? (8 posts)

  1. justcreativedesign
    Member
    Posted 6 years ago #

    Hi,

    I have just disabled about 5 of my plugins and now only the front page of my website (www.justcreativedesign.com) works (all the other pages display a 404 error).

    Originally my permalink structure was
    /%year%/%monthnum%/%day%/%postname%/
    but now every page gives me a 404 error except the home page.

    I have found if I change my permalink structure back to default (I have it there atm until someone can help me out) that all of the pages work however I want to change back to my old permalink structure for obvious reasons however when I do so nothing works.

    I believe the problem may lie with my htaccess file (which is atm 100% blank). I am not sure what should be there?

    and my website is 100% the root directory if that would help.

    If anyone could help me out with this issue, it would be appreciated.

    Thanks.

    PS. I emailed my host company regarding this and they said...

    There is nothing wrong with anything on our end. We cannot help you with your issue.

    The only thing that has changed is you doing what is listed below.

    Try undoing all of the changes you made excepecially to .htaccess files created by content management systems that rewrite URLs.

  2. Jeremy Clark
    Moderator
    Posted 6 years ago #

    Try switching your permalinks back and see if your .htaccess file updates. If wp can't it should print out the code and instructions telling you to manually edit your .htaccess file.

  3. justcreativedesign
    Member
    Posted 6 years ago #

    Thanks for the reply. I did try changing it back and did check the htaccess file however it was still blank. No instructions?

  4. justcreativedesign
    Member
    Posted 6 years ago #

    Anyone have a solution?

  5. justcreativedesign
    Member
    Posted 6 years ago #

    PS.
    I have also just found out that if i add index.php infront of my posts as below, it works?

    http://justcreativedesign.com/index.php/2007/12/12/101-places-to-get-design-inspiration/

    How can I get rid of the index.php bit?

  6. AskApache
    Member
    Posted 6 years ago #

    What does the RewriteRules / Permalinks Debugger Plugin tell you?

    try chmodding your /.htaccess to 644 and updating your permalinks..

    try adding this to your .htaccess

    DirectoryIndex /index.php
    
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
  7. amitpatel3001
    Member
    Posted 6 years ago #

    Did you chmod your htaccess to 666 temporarily and check out?

  8. justcreativedesign
    Member
    Posted 6 years ago #

    Hi, thanks everyone... I have fixed the problem...

    I added this to my htaccess

    # BEGIN WordPress

    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

Topic Closed

This topic has been closed to new replies.

About this Topic