WordPress.org

Ready to get started?Download WordPress

Forums

Permalink problem (upgrading 2.1 to 2.5) (8 posts)

  1. sms4smile
    Member
    Posted 5 years ago #

    Hi,

    I am about to upgrade 1 of my critical blog from wordpress version 2.1 to 2.5 and a very critical problem I am facing is with the permalinks.
    Currently, I am using following permalink (/%category%/%postname%.html) and I deeply wish not to change it for any cost.The problem is illustrated as follows

    look at the permalink of a category in wordpress 2.1
    ====================================================
    http://testdomain.com/category/test-category/

    Now,look at the permalink of a category in wordpress 2.5
    ========================================================
    http://testdomain.com/category/test-category

    the ending / after category name is removed automatically, that I don't wish to.

    I urgently need a workaround to this problem I don't want to use permalink redirect plugin and don't wish to change permalink.Hence I want to keep using (/%category%/%postname%.html) with ending slash in category links.
    Can anybody help or refer this thread/question to a wordpress moderator?

    Thanks in advance.

  2. P. Chandra
    Member
    Posted 5 years ago #

    I think you can sort this issue by editing .htaccess

  3. wpcast
    Member
    Posted 5 years ago #

    yep, some well written rewrite conditions and rules will solve this no problem.

  4. wpcast
    Member
    Posted 5 years ago #

    Trailing Slash Problem

    The solution to this subtle problem is to let the server add the trailing slash automatically. To do this correctly we have to use an external redirect, so the browser correctly requests subsequent images etc. If we only did a internal rewrite, this would only work for the directory page, but would go wrong when any images are included into this page with relative URLs, because the browser would request an in-lined object. For instance, a request for image.gif in /~quux/foo/index.html would become /~quux/image.gif without the external redirect!

    So, to do this trick we write:

    RewriteEngine  on
        RewriteBase    /~quux/
        RewriteRule    ^foo$  foo/  [R]

    The crazy and lazy can even do the following in the top-level .htaccess file of their homedir. But notice that this creates some processing overhead.

    RewriteEngine  on
        RewriteBase    /~quux/
        RewriteCond    %{REQUEST_FILENAME}  -d
        RewriteRule    ^(.+[^/])$           $1/  [R]

    **from http://httpd.apache.org/docs/2.0/misc/rewriteguide.html

  5. sms4smile
    Member
    Posted 5 years ago #

    Well, first of all if I think that .htaccess will resolve the problem than he best and the easiest way to get it done is copy & paste the previous / old .htaccess file to the new one.and I did the same but still the categories are showing without /

  6. stvwlf
    Member
    Posted 5 years ago #

    I have used the robots-meta plugin to solve the problem of the missing trailing slash. One of the options you can turn on in that plugin's admin is to force WP to always use the trailing slash. Works well.

  7. MichaelH
    Member
    Posted 5 years ago #

  8. dopecoder
    Member
    Posted 5 years ago #

    Hi
    see this 5 step tutorial that tells you how to add trailing slash to a category. Please note this is only for wordpress 2.6+
    http://bloggerholic.com/wordpress/how-to-add-trailing-slash-to-a-category-144.htm

Topic Closed

This topic has been closed to new replies.

About this Topic