WordPress.org

Ready to get started?Download WordPress

Forums

Permalink problem - is "site" a reserved word? (3 posts)

  1. jwheck
    Member
    Posted 4 years ago #

    I have 2 WordPress installs on the same domain and server. Custom (pretty) permalinks worked on one, but not the other. (Domain names changed to protect the innocent.)

    http://www.mysite.com/site
    which is in development. And
    http://www.mysite.com/wordpress
    which has been around for a while.

    Both have the custom permalink setting of /%category%/%postname%/

    /site gives me a 404 error.
    /wordpress works fine.

    Their .htaccess files are identical except that /wordpress's says "wordpress" where /site's says "site".

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /site/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /site/index.php [L]
    </IfModule>
    
    # END WordPress

    The server is a Deluxe Linux server on Godaddy.

    I followed the standard method of waiting after setting up the permalinks on a Godaddy server. I waited for days and /site still did not work.

    /wordpress did not have the custom permalinks on yet. It started working immediately after switching. (I think there may have been an existing empty .htaccess file.)

    So, same versions of WordPress, same Linux server, similar setup, no weird plugins, same .htaccess file, same database with different prefixes for the tables.

    I have tried reinstalling /site using the built-in updater. I even tried deleting the database tables and uploading a fresh install of WordPress.

    Then I had the idea to rename the "site" folder thinking maybe "site" was a reserved word or something. So I went into the General settings, changed the paths to http://www.mysite.com/web, saved changes, and used FTP to change the folder name from "site" to "web".

    It worked.

    Even the .htaccess file was automatically changed.

    Just to be sure, I changed "web" back to "site" and the permalinks stopped working until I changed it back to "web".

    Does anyone have any insight? Is this a WordPress, Apache, or Godaddy thing?

    I'm happy that it's working, so no rush. Mostly I'm posting this to help anyone who has a similar problem.

  2. Shane G
    Member
    Posted 4 years ago #

    Hi,

    You need to add the .htaccess file in your blog and add the code separate in that which may resolve the case.

    Also for the 404 post you can add this code in htaccess:

    # BEGIN WordPress

    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Thanks,

    Shane G.

  3. Samuel B
    moderator
    Posted 4 years ago #

    it should work with site - I just tested it

    completely delete the .htaccess in /site
    now regenerate your custom permalinks

Topic Closed

This topic has been closed to new replies.

About this Topic