WordPress.org

Ready to get started?Download WordPress

Forums

Events Planner
[resolved] Permalink problem and event (post) content just displays [wpuf_addpost] (4 posts)

  1. PinkishHue
    Member
    Posted 1 year ago #

    Hi,

    I just installed this on 3.4.1

    I added an event with a title of 'Testing an Event' but noticed the permalink had set itself to something like 'test', maybe it was 'testing', anyway - so I manually changed it to 'testing-an-event' and then when publishing the event and trying to view it I got a page not found error.

    So I edited the permalink back to 'testing' and then I could access the event on the front end.

    But, instead of display any content for the event it displays this shortcode [wpuf_addpost]

    I will have to move on and try to find another plugin but wanted to let the developer know.

    Thanks! I'm sure this is a very useful plugin when it's working properly.

    http://wordpress.org/extend/plugins/events-planner/

  2. Abel S
    Member
    Plugin Author

    Posted 1 year ago #

    Hi PinkishHue.

    Since Events planner uses custom post types, the permalink is created automatically based on WordPress standard functions so I am not doing anything special. As far as "Page not Found", that is because of WP rewrite rules. They need to be flushed. Please visit Settings > Permalinks page in WordPress admin and that should do it. As far as the shortcode [wpuf_addpost], I am not sure what that is. By default, the single event page will use your theme's single.php file to display content. If you are seeing the shortcode on there, that means maybe the template file is not properly coded!?

    Hope this helps. The plugin has been working very well for a lot of people. But unfortunately, with the infinite combinations of themes and plugins, some anomalies are bound to happen.

    Thanks, Abel

  3. PinkishHue
    Member
    Posted 1 year ago #

    Thank you Abel, it probably was to do with flushing the permalinks, I wasn't aware of that issue when testing your plugin.

    Either that or a conflict with another plugin.

    No worries, thank you for your response. I will mark this as resolved :)

  4. Abel S
    Member
    Plugin Author

    Posted 1 year ago #

    @PinkishHue, sounds good. Thank you.

    Abel

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.