WordPress.org

Ready to get started?Download WordPress

Forums

Permalink problem after upgrade (24 posts)

  1. BrokenPerfection
    Member
    Posted 6 years ago #

    URL: http://brokenperfection.com/blog1
    Host is Yahoo!

    I cant seem to get the permalinks to work on my blog after I updated to 2.3. this is the error I get when clicking on them:

    Error: The page isn't redirecting properly

    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    * This problem can sometimes be caused by disabling or refusing to accept
    cookies.

  2. Chris_K
    Member
    Posted 6 years ago #

    As I recall, the only way pretty Permalinks work with Yahoo is if you're running their permalink plugin.

    Are you?

  3. BrokenPerfection
    Member
    Posted 6 years ago #

    Yes it is running

  4. Chris_K
    Member
    Posted 6 years ago #

    If you disable their plugin, and set your Permalinks to default, do things work?

    If their permalinks plugin is breaking things, I'm afraid you may have to contact Y! directly to see if they'll be fixing/upgrading it soon.

  5. BrokenPerfection
    Member
    Posted 6 years ago #

    HA you rule! Thats what it is.. I work for yahoo! so I will see what I can do about this when I get into to work tomorrow..

  6. Chris_K
    Member
    Posted 6 years ago #

    Sweet -- it would be very helpful if you let us know how that goes. :-)

    I bet you won't be the last one trying the upgrade.

  7. BrokenPerfection
    Member
    Posted 6 years ago #

    Ok so a ticket to Y! enginerring has been sent.. However is anyone Knows why the Yahoo! permalinks plugin breaks permalinks in 2.3 or wants to give it a shot and try and fix it heres the code I pulled it from the php file:

    <?php
    /*
     * Copyright (c) Yahoo! Inc. 2005. All Rights Reserved.
     *
     * This file is part of Yahoo Permalink Plugin. The Yahoo Permalink Plugin
     * is free software; you can redistribute it and/or modify it under the terms
     * of the GNU General Public License as published by the Free Software
     * Foundation under version 2 of the License, and no other version. The Yahoo
     * Permalink plugin is distributed in the hope that it will be useful, but WITHOUT
     * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
     * FOR A PARTICULAR PURPOSE.  See the
     * GNU General Public License for more details.
     * You should have received a copy of the GNU General Public License
     * along with the Yahoo Permalink plugin; if not, write to the Free Software
     * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
     */
    
    /*
    Plugin Name: Customizable Permalinks
    Plugin URI: http://smallbusiness.yahoo.com/webhosting/
    Description: Help drive and retain traffic to your site with the Customizable Permalinks plug-in, which enables you to give your readers easily understandable, static web addresses (URLs) for your pages. Customized permalinks make it easier for your readers to bookmark and share your blog posts.
    Author: Yahoo! Web Hosting
    Version: 1.0
    Author URI: http://smallbusiness.yahoo.com/webhosting/
    */
    
    function update_permalink_file() {
      if (isset($_POST['permalink_structure']) ) {
        if(empty($_POST['permalink_structure']) ) {
          unlink(get_home_path() . '.plink');
        } else {
          touch(get_home_path() . '.plink');
        }
      }
    
      if(strcmp($_GET['deactivate'],"true")==0){
          unlink(get_home_path() . '.plink');
      } else if(strcmp($_GET['activate'],"true")==0){
          touch(get_home_path() . '.plink');
      }
      unlink(get_home_path() . '.htaccess');
    }
    
    // Now we set that function up to execute when the admin_footer action is called
    add_filter('mod_rewrite_rules', 'update_permalink_file');
    add_action('mod_rewrite_rules', 'update_permalink_file');
    ?>
  8. deaconjim
    Member
    Posted 6 years ago #

    Mark Jaquith of Mark on WordPress discusses WordPress 2.3 Canonical URLs and the problems they may cause.

    He has a one line plug-in that disables canonical URL redirection.

    I installed the plug-in and reactivated the Yahoo! plug-in. Everything works now. I will use this until Yahoo corrects its issues - or until I move to a different provider.

  9. bryanh30
    Member
    Posted 6 years ago #

    Deaconjim/Broken:

    Is this all you had to do to upgrade Yahoo to 2.3? I want to do the same and not familiar with making files writable and stuff. I upgraded to 2.3 then had to put my backup back on because the permalinks would not work -- are there any other problems because if not then I will try again with this solution... thanks very much for posting this!!!

    Bryan

  10. deaconjim
    Member
    Posted 6 years ago #

    Bryahn,

    Yes, that's it - and it worked perfectly.

    An aside is that I always get database update errors when I upgrade - and there are database changes in version 2.3. I have to manually run the SQL statements. After doing that it works fine, but that may just be a problem with my Yahoo install and security structure.

    At the present time I'm just too lazy to leave Yahoo - but the day is drawing closer...

  11. pnair123
    Member
    Posted 6 years ago #

    We switched to 2.3.1 recently and noticed the site was slow..After troubleshooting found out that the customizable permalinks was the cluprit .Took it out..Now its fast.Check out our site at bloggermoms

  12. joshkaufman
    Member
    Posted 6 years ago #

    Hello,

    I am running wp 2.3.3. The site is hosted on Yahoo. The yahoo custom permalinks plugin is installed an activated.

    I have also installed the plugin to disable canonical URLS. I still cannot get permalinks to work correctly. The site in question is http://www.showukare.com.

    An example of the problem is http://www.showukare.com/faq.

    I have a page with the page slug of "faq" but it will not load. The page will load is you use the default link structure:
    http://showukare.com/?page_id=2

    Is there anything I can do to get this to work with this setup?

  13. Shivanand The Designer
    Member
    Posted 6 years ago #

    Essentially the new yahoo permalink plugin already disallows the cannonical urls. however there's nothing you can do if installing WP in the root directory.

    If you are simply moving to a different directory, yahoo has an interface to change the directory name to fix the permalinks. It's under the "Blog Manager". Ref http://help.yahoo.com/l/us/yahoo/smallbusiness/webhosting/wordpress/wordpress-26.html

  14. jaket
    Member
    Posted 6 years ago #

    Varun, is there anything else you did to set this up? You seem to be the only one I've found who got permalinks to work correctly with yahoo. I installed the new Yahoo Permalink Plugin (with the disallow cannonical urls line), but it still only works if I include the "index.php" in there. I have found people who have setup permalinks with yahoo, but they all included the blog directory, e.g., "http://mysite.com/blog/welcome-to-mysite".

    Here's the blog Im trying to setup:
    http://blog.plazalingua.com/2008/04/09/welcome-to-plazalingua/

    Any ideas would be appreciated. Thanks!!

    Jake

  15. CodeCritic
    Member
    Posted 6 years ago #

    Has anyone succeeded here to get rid of index.php from the url?

    if so, please provide what you did to fix this on Yahoo! please.

    Thanks,
    http://codecritic.in

  16. firassalim
    Member
    Posted 6 years ago #

    My Yahoo! Customizable permalink plugin is not even being activated when I upgraded from 2.0.2 to 2.5.1
    Database errors was a long list when I upgraded!

  17. abhijitmaleth
    Member
    Posted 6 years ago #

    Hi,
    After almost 2 weeks of research,I seemed to have found a moderate solution.Assuming you have installed wordpress on your own,here are some steps to obtain pretty permalinks(almost).

    1)Install Canonical Url Disable Plugin

    2)Go to Settings in your administration panel(Site Admin)

    3)Go to General Tab

    4)Change the Blog Url to http://www.example.com/index or http://www.example.com/index.php(Both Work,if not do tell me!)

    5)Now,Go to Permalinks Tab.

    6)Select one of the pretty permalinks.

    That's it.Though Iam not sure how /index works.I guess it is something unique to Yahoo Webhosting.

    You can visit my site to see how it works.Epics of India

  18. laroca
    Member
    Posted 6 years ago #

    abhijitmaleth,

    I did what you said to do and it ruined my blog. I changed the blog URL to http://www.juliotavarez.com/info/index.php and now I cant even get back to the admin page to fix it.

    Can someone help me fix my blog?

    Thanks!

  19. abhijitmaleth
    Member
    Posted 5 years ago #

    Hey Laroca,
    I think you must have changed the WordPress address (URL).That's probably the reason you can't get back to your admin page.It has happened to me also.Please read the instructions carefully!It says Blog Address(URL).As for getting your blog back online,I think adjusting the URL in your MySql table should do the trick.

    Guys please read the instructions properly.It is the BLOG URL that you have to change not the WordPress URL.

    abhijitmaleth,

    I did what you said to do and it ruined my blog. I changed the blog URL to http://www.juliotavarez.com/info/index.php and now I cant even get back to the admin page to fix it.

    Can someone help me fix my blog?

    Thanks!

  20. williams94086
    Member
    Posted 5 years ago #

    For the disable canonical links plugin, is it just a php file that I add to my root file system? You say 'install' and I'm uncertain what I need to do since it's just a file.

    I added the file to my root and changed the blog URL. The post urls now look pretty, but when they are clicked they redirect to a URL without the index.php and therefore give a 404.

    Any thoughts on what I'm doing wrong? You can see this at:

    http://recoveredrecipes.com/index.php/2008/08/permalinks-final-test/

  21. Kim Parsell
    Volunteer Moderator
    Posted 5 years ago #

    You need to upload the disable canonical links plugin file to your wp-content/plugins folder, then go to the Plugins page and activate it.

  22. williams94086
    Member
    Posted 5 years ago #

    kpdesign --thank you! Your info helped me to resolve my issue. I now have my permalink structure working. Whew ... that only took 3 days :-)

  23. Kim Parsell
    Volunteer Moderator
    Posted 5 years ago #

    You're welcome. :) Glad you got it all sorted out!

  24. abhijitmaleth
    Member
    Posted 5 years ago #

    Oops, sorry for being ambiguous in my instructions.Yes,as kpdesign rightly said,install means to upload the file to the plugins directory and then activating it as you would a normal plugin from the WordPress Dashboard.

    Anyways here are the modified instructions:

    1)Install Canonical Url Disable Plugin(install means to upload the file to the plugins directory and then activating it as you would a normal plugin from the WordPress Dashboard.)

    2)Go to Settings in your administration panel(Site Admin)

    3)Go to General Tab

    4)Change the Blog Url to http://www.example.com/index or http://www.example.com/index.php(Both Work,if not do tell me!)

    5)Now,Go to Permalinks Tab.

    6)Select one of the pretty permalinks.

    If you have any questions just contact me:admin@epics.in

Topic Closed

This topic has been closed to new replies.

About this Topic